15:01:28 <quaid> #startmeeting
15:01:28 <ovirtbot> Meeting started Mon Dec  3 15:01:28 2012 UTC.  The chair is quaid. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:28 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:38 <quaid> #topic Infra team weekly
15:02:56 <quaid> http://www.ovirt.org/Infrastructure_team_meetings
15:03:10 <quaid> ''Agenda''
15:03:10 <quaid> * MediaWiki & www
15:03:10 <quaid> * How to add new Infra admin members (if not resolved on list)
15:03:10 <quaid> * Hosting
15:03:10 <quaid> * Puppet
15:03:13 <quaid> * Jenkins
15:03:15 <quaid> * Gerrit
15:03:18 <quaid> * Other business?
15:03:20 <quaid> * Trac review
15:03:23 * ewoud here
15:04:14 * Rydekull is here, as usual :-P
15:04:27 * dneary here
15:04:33 * quaid just checking the discussion above
15:04:49 * dneary thinks we can drop MW & www from the agenda for next week
15:04:56 <quaid> hopefully
15:05:03 <dneary> This week can be a review of the migration, perhaps?
15:05:07 <quaid> ok, let's move on
15:05:12 <quaid> sounds like we have open problems
15:05:22 <quaid> #topic MediaWiki & www
15:05:37 <quaid> #info Migration to OpenShift and MediaWiki-only site complete last week
15:05:41 <ewoud> quaid: can you add some chairs?
15:05:47 <quaid> #info A few small issues may(?) remain
15:05:56 <quaid> #chair ewoud dneary
15:05:56 <ovirtbot> Current chairs: dneary ewoud quaid
15:06:16 <dneary> quaid, One issue related to my email to infra@ earlier
15:06:25 * quaid hasn't seen it yet
15:06:28 <dneary> http://ovirt.org/pagename is not redirecting
15:06:38 <quaid> I filed that ticket last night, yeah
15:06:50 <quaid> after Nick Coughlan's email about Download
15:06:51 <dneary> That's why there was a 404 for the old Download link
15:06:59 <quaid> https://fedorahosted.org/ovirt/ticket/18
15:07:04 <ewoud> today I had a weird issue with logging in, but nothing I could reproduce
15:07:14 <quaid> well, it was also because it was not pointed at [[Download]]
15:07:31 <dneary> quaid, I have a mod_rewrite fix for .htaccess, but didn't want to push without warning while the site is live
15:07:47 <dneary> quaid, www.ovirt.org/get-ovirt redirects properly
15:07:51 <quaid> dneary: yeah, I'd like to see it before you push
15:07:53 <dneary> quaid, ovirt.org/get-ovirt doesn't
15:08:09 <dneary> quaid, How do I do pull requests?
15:08:14 <dneary> quaid, Patch in trac?
15:08:32 <quaid> huh?
15:08:53 <dneary> quaid, I also updated MediaWiki:Sidebar to match Garrett's - the one you put in place still had the "Mailing lists" and "how to set up an account on the wiki" links
15:08:58 <quaid> I was wondering why it worked for Firefox and not other browsers
15:09:02 <quaid> or is that consistent?
15:09:09 <quaid> dneary: I didn't put that one in place
15:09:12 * dneary thinks we need a sync point
15:09:39 <quaid> dneary: I thought someone else changed it over the weekend, I didn't put in the "How to set up an account on the wiki"
15:10:05 <dneary> quaid, MediaWiki:Sidebar must have been a hold-over from the old wiki, over-written on Thursday
15:10:23 <dneary> The menu shown on Home must be generated from a different parameter
15:10:25 <quaid> dneary: not that we saw
15:10:33 <quaid> hmm, don't know about that
15:10:41 <quaid> I didn't see that toolbar that way when I left work on Friday
15:11:03 <dneary> Anyway, when I checked this morning my time, the top menu was not what I exepcted, I saw you'd made a change, and then I synced with what we had in Garrett's sandbox
15:11:09 <dneary> So should be all good now
15:11:34 <quaid> this is rather odd
15:11:52 <quaid> this is not the first page we've encountered where there appeared to be a regression to old content
15:11:59 <quaid> anyway, as long as it doesn't go back _again_ :)
15:12:08 <ewoud> garrett: dneary btw, I'm seeing the same login issue again btw so it may be related to some addon in my FF
15:12:26 <dneary> ewoud, Did you create a trac for this?
15:12:29 <quaid> http://www.ovirt.org/index.php?title=MediaWiki:Sidebar&curid=114&action=history Doesn't show an edit until mine, but I'm sure it wasn't that way
15:12:33 <garrett> ewoud: it might be. can you try disabling your extensions so we can figure out which one?
15:12:38 <ewoud> dneary: not yet, only just noticed I could reproduce it
15:12:39 <garrett> it could be something that rewrites the page
15:12:42 <dneary> Since I don't see the same thing, some reproducibility steps would be helpful
15:13:32 <dneary> quaid, This is what I was seeing: http://www.ovirt.org/index.php?title=MediaWiki:Sidebar&oldid=3997
15:14:05 <quaid> dneary: to be clear, I saw that last night
15:14:10 <quaid> dneary: but it wasn't that way on Friday
15:14:20 <dneary> OK
15:14:28 <quaid> dneary: I changed only the Download link because I didn't know if one of you had added the How to ... link etc.
15:14:39 <quaid> dneary: so I didn't want to just change it without discussing, etc.
15:14:45 <dneary> OK
15:14:54 <quaid> I didn't actually look at the history, or I would have seen it wasn't changed, and been even more confused :)
15:15:02 <dneary> Yes
15:15:04 <dneary> Me too
15:15:19 <dneary> Now - what was that about a FF specific issue?
15:15:28 <dneary> I didn't understand that comment
15:15:45 <quaid> http://ovirt.org/get-ovirt (for example) seems to work for me in Firefox, but not Chrome nor links
15:15:55 <quaid> when I tested redirects last week, it was mostly with Firefox
15:16:05 <quaid> so I didn't see that naked domain wasn't redirecting
15:16:17 <quaid> I presumed the same for the rest of us, since none of us noticed the .htaccess wasn't quite right in that way?
15:16:35 <Rydekull> quaid: not working in my FF
15:16:48 <quaid> dneary: want to fpaste your .htaccess?
15:17:03 <quaid> if it looks good, we should push - we've got old links broken, basically
15:17:27 <dneary> quaid, Just attaching it to the trac
15:18:03 <quaid> great
15:19:02 <quaid> garrett: I'm still unable to see the base font in Firefox, btw
15:19:12 <garrett> quaid: which font?
15:19:17 <garrett> oh
15:19:18 <garrett> really?
15:19:19 <garrett> odd
15:19:26 <garrett> are you connecting to it from the same server?
15:19:48 <quaid> garrett: I thought we could work on it later, since I seem to be the only one with this problem
15:20:04 <garrett> quaid: are you connecting from the same protocol and server as the one the font is hosted on?
15:20:21 * quaid parses that question
15:20:33 <garrett> # Fix fonts for Firefox
15:20:33 <garrett> <FilesMatch "\.(ttf|otf|woff)$">
15:20:33 <garrett> <IfModule mod_headers.c>
15:20:33 <garrett> Header set Cache-Control "max-age=29030400, public"
15:20:33 <garrett> Header set Access-Control-Allow-Origin "*"
15:20:34 <garrett> </IfModule>
15:20:36 <garrett> </FilesMatch>
15:20:41 <garrett> put that in the .htaccess
15:21:22 <quaid> garrett: can I test that just for myself?
15:21:27 <garrett> nope
15:21:37 <garrett> put that in, make sure the page loads, and you should be good
15:21:42 <garrett> as long as mod_headers is there
15:21:54 <garrett> but it shouldn't break if it isn't, as the if should check for it
15:22:43 <quaid> ok, I'll try that later today when the wiki is't being used
15:22:54 <dneary> quaid, One other tracworthy migration-related point: can we get bot notices of wiki edits back, please?
15:23:02 <dneary> (will create the trac now)
15:23:18 <quaid> dneary: I don't know how to do that, actually
15:23:34 <dneary> Who set up the bot previously?
15:23:43 <quaid> dneary: I was going to look in to running a supybot instance inside openshift somehow
15:23:44 <Rydekull> who's running the bot?
15:23:52 <quaid> we are, i set it up
15:23:59 <quaid> ianweller wrote the MediaWiki extension
15:24:12 <quaid> I haven't tested if it will work for a remote install, I think it expects to be o nthe same host as the wiki
15:24:21 <Rydekull> Cant be that hard to figure out then?
15:24:26 <quaid> dneary: go ahead and file a ticket, we'll have to do more investigation
15:24:30 <dneary> quaid, I can try to have a look
15:24:45 <quaid> well, we can just ask Ian for a shortcut :)
15:25:02 <quaid> unless you want to go read the php guts :)
15:25:14 <quaid> #info Need to work on supybot mediawiki connection
15:25:28 <quaid> dneary: that htaccess rule looks sane to me
15:25:45 <quaid> https://fedorahosted.org/ovirt/attachment/ticket/18/ovirt.org_redirect.patch Patch to fix the .ovirt.org -=> www.ovirt.org
15:25:56 <quaid> anyone else want a look?
15:26:17 <quaid> dneary: how do you feel about us pushing that?
15:26:30 <quaid> I know it creates an outage for 20 seconds or so
15:26:50 <dneary> quaid, The question arises: since a push results in a ~30s website outage, what should we do as good sysadmins?
15:27:09 <dneary> I don't want to have people try to save wiki edits only to get a "this website is down" warning
15:27:14 <quaid> let's do this
15:27:28 <ewoud> sorry, was a bit afk
15:27:35 <dneary> Should we batch changes and do them at a useful time?
15:27:37 <quaid> how about we send an email now that we're pushing a fix in 30 minutes at the end of this meeting?
15:27:54 <dneary> Is there a way to notify wiki users?
15:27:58 <quaid> dneary: it's just because the redirect URls are broken, people I think are going to get broken links
15:28:14 <quaid> wiki doesn't really track who-is-editing state afaik
15:28:36 <ewoud> maybe we need some standard way to announce things
15:28:36 <quaid> maybe it's not such a big deal? we can wait?
15:28:41 <quaid> ewoud: yep :)
15:28:54 <Rydekull> Or, schedule hours where you do changes
15:28:57 <quaid> ewoud: last week we forgot to include users@ and announce@, so that's something
15:29:07 <quaid> Rydekull: as in, a regular maintenance window?
15:29:14 <Rydekull> Like so, yes
15:29:55 <ewoud> quaid: not sure how lists in lists work, but maybe we need infra-announce@ and make users@ and announce@ members?
15:30:09 <quaid> sure, that could work
15:30:17 <quaid> lists in lists usually works
15:31:53 <Rydekull> In essence, Critical and non-critical changes. Critical changes, an hours notice. Non-critical, in maintenance window.
15:32:14 <quaid> there ya go
15:32:27 <quaid> that's the question, is the current .htaccess not working right a Critical issue?
15:32:48 <quaid> any votes/comments?
15:32:55 <quaid> we can decide that and move on I think
15:32:57 <Rydekull> What is it preventing? Something in the core of ovirt.org? If so Critical
15:33:14 <quaid> fwiw, I filed it as critical in relation to the migration
15:33:27 <Rydekull> So, Critical :-)
15:33:41 <quaid> Rydekull: presumably, anybody with ovirt.org in their history or incoming links won't work
15:34:03 <Rydekull> Critical then, quite visibly
15:34:41 <quaid> works for me
15:34:51 <quaid> dneary: what do you think?
15:35:05 <dneary> OK
15:35:09 <dneary> You're the boss :)
15:35:26 <dneary> (es)
15:35:45 <dneary> And Rydekull's suggestion sounds sane to me
15:35:50 <dneary> So - in 1h?
15:36:26 <quaid> yeah
15:36:34 <dneary> I don't think things like this should go to announce@ by the way
15:36:50 <quaid> #agreed Going to push .htaccess change in 1 hour after sending an announcement around, as this is a critical change
15:36:53 <dneary> That's for project-related announcements, not for administravia
15:37:05 <quaid> #agreed Critical changes can happen immediately (if no choice) or announced for 1 hour away
15:37:15 <quaid> dneary: works for me
15:37:21 <quaid> dneary: would you include users@
15:37:26 <dneary> so - users, arch, infra?
15:37:36 <quaid> I tend to not think of users@ as people editing the wiki, but that's probably bad prejudice on my part
15:37:51 <quaid> users, arch, infra works
15:38:16 <quaid> #info users, arch, infra lists seem a sane default for administrivia on infra items
15:38:30 <dneary> It will get annoying quick if we need to restart every time we want to modify a config file
15:38:31 <quaid> ok!
15:38:42 <quaid> yep
15:38:46 <quaid> downside of openshift, I guess
15:38:51 <dneary> Is there a way to tell OpenShift that a change doesn't require service restarts, and just needs a git pull?
15:39:01 <quaid> otoh, the way of the cloud is not how long can I keep it up, but how quickly can I recover
15:39:12 <quaid> dneary: perhaps
15:39:51 <quaid> dneary: are you going to be around in an hour to push the change?
15:40:06 <quaid> & would like to send the email? or need me to do it?
15:40:08 <dneary> I'll be on the phone with lh, but can take a second to do that
15:40:12 <dneary> Writing the announcement now
15:40:48 <quaid> ok great
15:40:51 <ewoud> maybe I'm missing something
15:41:02 <ewoud> but shouldn't this redirect be applied to linode01?
15:41:20 <quaid> #action dneary to make announcement & push .htaccess change
15:41:33 <ewoud> ovirt.org resolves there so that needs to redirect to the correct www. which points to openshift
15:42:24 <quaid> huh
15:42:32 <quaid> you are correct, actually
15:42:52 <quaid> (it's early for me, wasn't thinking that through :)
15:43:09 <quaid> dneary: ^^^^
15:43:24 <dneary> quaid, In that case, the change can be made (by you) straight away
15:43:41 <ewoud> and I see dneary already mailed, but that's no harm
15:43:44 <dneary> I thought the issue was that ovirt.org was a server alias on www.ovirt.org
15:43:55 <ewoud> no, you can't CNAME domain.tld
15:44:00 <dneary> Yes, /me was busy working instead of meeting :)
15:44:14 <ewoud> that can greatly screw you over and is not allowed by the RFCs I think
15:44:46 <dneary> quaid, So that 3 line change needs to be made on resources.ovirt.org, and then Apache restarted
15:45:51 <quaid> #agreed oops, we meant to do all that to linode01.ovirt.org
15:45:55 <quaid> ok, I'll do that
15:46:01 <quaid> anything more on this topic?
15:46:53 <dneary> What we can do is fix the problem, and in an hour announce that it's fixed
15:46:55 <dneary> :)
15:48:22 <quaid> ok
15:48:32 * Rydekull got a phonecall, but is back now
15:48:34 <dneary> Can I just skip to the Hosting topic before I have to go for a call?
15:48:49 <quaid> I think we'll do that and maybe close
15:49:02 <quaid> #topic Hosting
15:49:21 <quaid> #info first minor hosting shift is complete with OpenShift migration
15:52:12 <quaid> dneary: go ahead
15:52:50 <dneary> I got word back from legal about the hosting agreement
15:53:07 <dneary> It was rejected because it was missing an annex mentioned in the agreement
15:53:16 <quaid> natch
15:53:21 <dneary> I'm following up on all sides (RH Legal and AlterWay) to resolve
15:53:50 <dneary> But everyone is aware that Kevin Mazière is there to help us - we just need to tell him what we need and ask him when we'll have it
15:54:13 <dneary> quaid, Ball's in your court now?
15:54:53 <quaid> dneary: sorry, which ball?
15:55:15 <dneary> Getting Jenkins running on the server they've agreed to host for us
15:55:32 <dneary> I had understood you were taking the lead on that
15:55:47 <dneary> And that you felt it was a very high priority now that the website is live
15:56:33 <quaid> dneary: plan is to deploy using Puppet, but sounds like we need to revive the what-where conversation
15:56:41 <dneary> quaid, Yes
15:56:55 <quaid> #info Legal bounced the contact back for a missing annex, fix in the works
15:57:03 <dneary> I would suggest first step is getting access to the bare metal, letting him know which OS we want to run on it, etc
15:57:25 <quaid> #action quaid to (re)start the who-what-where conversation about Jenkins, AlterWay, etc.
15:59:12 <quaid> ok then
15:59:56 <quaid> ewoud: would you like to talk about puppet/foreman here, or keep on the list with that?
16:00:05 <quaid> we can continue or close the meeting, basically :)
16:00:46 * ewoud back
16:01:08 <ewoud> quaid: I haven't done anything in the last week so nothing new :S
16:01:57 <quaid> :)
16:02:09 <quaid> ok, any objections to just closing the meeting at this point and moving on?
16:05:00 <quaid> heh  ok
16:05:37 * quaid is back from network drop
16:05:42 <quaid> and we're closing
16:05:49 <quaid> thanks for coming today folks
16:05:58 <quaid> worthwhile session, I think :)
16:06:03 * quaid closing in 10 seconds
16:06:18 <quaid> #endmeeting