#ovirt: oVirt Infra weekly

Meeting started by quaid at 15:00:17 UTC (full logs).

Meeting summary

  1. Agenda (quaid, 15:02:24)
  2. MediaWiki & www (quaid, 15:04:16)
    1. Remaining problem of a mod_rewrite rule to get the logo visible (quaid, 15:05:04)
    2. http://fpaste.org/NEgP/ (quaid, 15:07:42)
    3. http://wiki-ovirt.rhcloud.com/skins/common/images/oVirt-logo.png (quaid, 15:08:06)
    4. process to transfer sites should take 45 to 90 minutes (quaid, 15:12:57)
    5. ACTION: quaid to arrange DNS cutover timing based on the idea that we'll have this working within 2 days (quaid, 15:13:18)
    6. need to make sure wiki images are showing up in pages (quaid, 15:19:45)

  3. MediaWiki backup script (quaid, 15:19:56)
    1. I forgot to remove this topic but I think we're covered with this because we'll need a new backup procedure for the new OpenShift based tool (quaid, 15:20:32)
    2. of course if I write that script it may have the same problem, so I'll be coming back later for help on that :) (quaid, 15:20:48)

  4. Hosting (quaid, 15:20:56)
    1. My Red Hat IT contact told me last week he is provisioning two servers at RackSpace for us, bare metal to use as we wish (quaid, 15:21:23)
    2. RackSpace servers should be available this week or next, depending on how fast the paper churns (quaid, 15:21:44)
    3. We're also proceeding with plans for Alter Way work, and may start installing & such but not switchover data until paper churns there (quaid, 15:23:28)
    4. ACTION: quaid to tell people status of 'broken' script & to please hang on (quaid, 15:25:06)

  5. Trac review (quaid, 15:27:15)
    1. I'm moving this topic to the end of the meeting, as it's a bit of administrivia that we don't need to do in the middle - often it's covered by other open items anyway, so putting it at the end will make it faster (quaid, 15:27:43)
    2. ACTION: quaid to move this topic to the end of the agenda permanently (quaid, 15:27:55)

  6. Puppet (quaid, 15:28:30)
    1. ewoud has a proof of concept (POC) Foreman install running: (quaid, 15:30:45)
    2. https://foreman.ekohl.nl (quaid, 15:30:57)
    3. ewoud is working on the initial Puppet manifests (quaid, 15:31:25)
    4. ACTION: quaid, dcaro, dneary will help ewoud with Puppet manifests (quaid, 15:34:06)
    5. Puppet manifest discussion to happen on infra@ovirt.org ASAP (quaid, 15:34:51)

  7. Jenkins (quaid, 15:39:54)
    1. jenkins.ovirt.org updated to latest for security fix (quaid, 15:41:06)
    2. ACTION: we should consider using openid auth in new jenkins server (eedri, 15:43:04)
    3. we've been adding new power users, who offest the load on the Infra tream by enabling people with experience to enhance sub projects in Jenkins (quaid, 15:43:18)
    4. IDEA: we should consider using openid auth in new Jenkins server (quaid, 15:43:40)
    5. ACTION: eedri will work on OpenID for Jenkins (quaid, 15:45:32)
    6. ACTION: oVirt Infra to make a Foreman feature request to have OpenID (quaid, 15:46:30)
    7. ACTION: quaid to look in to MediaWiki and OpenID (quaid, 15:46:39)

  8. Puppet/Foreman (quaid, 15:48:47)
    1. AGREED: using foreman rpms deployments is better than using the foreman git repo (quaid, 16:01:53)

  9. Gerrit (quaid, 16:02:06)
    1. I think the Infra git repo is available, but I haven't put anything in it (quaid, 16:02:26)

  10. Process for bringing in new people to INfra (quaid, 16:04:15)
    1. we need a discussion on list where everyone can be involved (quaid, 16:04:32)
    2. ACTION: quaid to start new thread ASAP (quaid, 16:04:51)

  11. Trac review (quaid, 16:06:02)
    1. https://fedorahosted.org/ovirt/report/1 (quaid, 16:06:11)
    2. https://fedorahosted.org/ovirt/ticket/10 (quaid, 16:06:47)
    3. renaming of mailing list arch > devel is happening after the www/wiki transfer is all worked out, priority-wise (quaid, 16:07:16)
    4. ACTION: quaid needs to put together a migration plan, so people are warned to fix mail filter rules, etc. (quaid, 16:07:37)
    5. https://fedorahosted.org/ovirt/ticket/11 (quaid, 16:07:55)
    6. slow mailing list show resolve when we move it to Alter Way, leaving this open for now so we can be sure it is better (quaid, 16:08:11)
    7. https://fedorahosted.org/ovirt/ticket/13 (quaid, 16:08:46)
    8. Is this an Infra task? (quaid, 16:09:06)
    9. ACTION: quaid to find out if this is an Infra ticket or now (quaid, 16:09:15)
    10. https://fedorahosted.org/ovirt/ticket/5 (quaid, 16:09:43)
    11. We'll need to have a how to file a ticket process in place one before doing all the hosting switching (quaid, 16:10:18)
    12. ACTION: quaid to takeover this ticket (quaid, 16:10:53)
    13. https://fedorahosted.org/ovirt/ticket/12 (quaid, 16:11:20)
    14. ACTION: quaid to revive the thread on this, get it fixed or lined up to change with new hosting (quaid, 16:11:59)


Meeting ended at 16:14:54 UTC (full logs).

Action items

  1. quaid to arrange DNS cutover timing based on the idea that we'll have this working within 2 days
  2. quaid to tell people status of 'broken' script & to please hang on
  3. quaid to move this topic to the end of the agenda permanently
  4. quaid, dcaro, dneary will help ewoud with Puppet manifests
  5. we should consider using openid auth in new jenkins server
  6. eedri will work on OpenID for Jenkins
  7. oVirt Infra to make a Foreman feature request to have OpenID
  8. quaid to look in to MediaWiki and OpenID
  9. quaid to start new thread ASAP
  10. quaid needs to put together a migration plan, so people are warned to fix mail filter rules, etc.
  11. quaid to find out if this is an Infra ticket or now
  12. quaid to takeover this ticket
  13. quaid to revive the thread on this, get it fixed or lined up to change with new hosting


Action items, by person

  1. dcaro
    1. quaid, dcaro, dneary will help ewoud with Puppet manifests
  2. dneary
    1. quaid, dcaro, dneary will help ewoud with Puppet manifests
  3. eedri
    1. eedri will work on OpenID for Jenkins
  4. ewoud
    1. quaid, dcaro, dneary will help ewoud with Puppet manifests
  5. quaid
    1. quaid to arrange DNS cutover timing based on the idea that we'll have this working within 2 days
    2. quaid to tell people status of 'broken' script & to please hang on
    3. quaid to move this topic to the end of the agenda permanently
    4. quaid, dcaro, dneary will help ewoud with Puppet manifests
    5. quaid to look in to MediaWiki and OpenID
    6. quaid to start new thread ASAP
    7. quaid needs to put together a migration plan, so people are warned to fix mail filter rules, etc.
    8. quaid to find out if this is an Infra ticket or now
    9. quaid to takeover this ticket
    10. quaid to revive the thread on this, get it fixed or lined up to change with new hosting
  6. UNASSIGNED
    1. we should consider using openid auth in new jenkins server
    2. oVirt Infra to make a Foreman feature request to have OpenID


People present (lines said)

  1. quaid (140)
  2. eedri (30)
  3. ewoud (28)
  4. dneary (21)
  5. dcaro (7)
  6. garrett_ (5)
  7. ovirtbot (5)
  8. karimb (4)
  9. ohadlevy (3)
  10. sgordon (1)
  11. adrian15 (1)
  12. Rydekull (1)


Generated by MeetBot 0.1.4.