15:01:28 <quaid> #startmeeting oVirt Infra Weekly
15:01:28 <ovirtbot> Meeting started Mon Oct 29 15:01:28 2012 UTC.  The chair is quaid. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:28 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:38 <quaid> #chair dneary
15:01:38 <ovirtbot> Current chairs: dneary quaid
15:01:54 <quaid> #topic roll & agenda
15:02:14 * quaid is walking to the coffee shopp
15:02:36 * dneary raises hand
15:05:13 <quaid> heh
15:05:21 <quaid> we had a quiet one lasg week, too
15:08:06 <dneary> hi acathrow
15:08:28 <dneary> We were looking for you earlier with mgoldboi re USB key workshop next week
15:10:12 <dneary> quaid, The main topic for me (and it's completely OK if we take this offline for me) is to figure out how the new hardware purchase might affect what we ask of Alter Way
15:10:46 * eedri_ here
15:10:56 <dneary> hi eedri_
15:11:10 <eedri_> hello... sorry the late arrival :)
15:11:21 * quaid is here again
15:11:56 <quaid> * MediaWiki & www
15:11:56 <quaid> * Hosting
15:11:56 <quaid> * Trac review
15:11:56 <quaid> * Puppet
15:11:56 <quaid> * Jenkins
15:11:58 <quaid> * Gerrit
15:12:01 <quaid> * Other business?
15:12:03 <quaid> http://wiki.ovirt.org/wiki/Infrastructure_team_meetings
15:12:16 <quaid> dneary: yep, we'll be there in 45 seconds
15:12:23 <quaid> because I don't have much to say on the first topic
15:12:29 <quaid> #topic Mediawiki & www
15:12:34 <quaid> #info garrett is ready for me
15:12:38 * sgordon is here
15:12:45 <quaid> #info I'm not quite ready for garrett
15:13:00 <dneary> quaid, Anything I can do to help re MediaWiki?
15:13:21 <quaid> #info ran in to confusion over the weekend with the upgrade, needed to wait until today when I can talk with the EPEL packager
15:13:52 <quaid> dneary: thanks, I think I can sort it out, it just keeps taking longer (the session to upgrade) than the time I have for it, and it exapands, and it's been not straightforward
15:14:28 <dneary> quaid, fyi, I'm almost ready for you too
15:14:43 <dneary> I need the newer mediawiki to ask for some new extensions
15:15:08 <quaid> #action quaid still owning upgrade
15:15:21 <quaid> #info quaid looking forward to OpenShift owning the platform upgrades
15:15:26 <quaid> #topic Hosting
15:15:32 <quaid> I sent out a big round-up email last week
15:16:01 <quaid> http://lists.ovirt.org/pipermail/infra/2012-October/001254.html
15:16:24 <quaid> what are the open questions from that?
15:16:36 <dneary> re Alter Way, there is one thing (hosting agreement) blocking on me
15:17:18 <quaid> yeah, I think I touched on the process in that email
15:17:27 <dneary> Alter Way have sent their standard hosting agreement, I need to get it signed by Red Hat (the easiest way would probably to get it signed by Red Hat France, which means explaining the situation in Paris, not a big deal, but slow)
15:17:27 <quaid> did that part work? make sense?
15:18:18 <dneary> I see that Stéphane has not yet replied to your email, so let me confirm with him that he's on infra@ and is dealing directly with you for any network & access requirements
15:19:20 <quaid> ok, I'd like to see the agreement, too
15:19:33 <quaid> is it in French? English version?
15:19:47 <dneary> It's in French
15:19:54 <dneary> Happy to forward it on to you
15:20:16 <quaid> thx
15:20:35 <quaid> Paris sounds like the ticket
15:21:22 <quaid> any other questions about those 3 hosting initiatives?
15:21:41 <quaid> I see them as very complementary, and providing a fair range of coverage
15:23:08 <ovirtbot> 14[[07Infrastructure team meetings14]]4 !10 02http://wiki.ovirt.org/w/index.php?diff=5005&oldid=4845&rcid=5125 5* 03Quaid 5* (+118) 10today's agenda
15:27:24 * ewoud here as well btw
15:27:48 <dneary> Sounds like that's a seal of approval.
15:27:55 <ewoud> nasty summer => winter time
15:27:59 <dneary> #topic Trac review
15:28:06 <quaid> thx
15:28:14 <dneary> quaid, Hope you don't mind that I took the liberty
15:28:19 <quaid> not at all :)
15:28:36 <quaid> https://fedorahosted.org/ovirt/report
15:29:12 <quaid> https://fedorahosted.org/ovirt/report/1
15:29:19 <quaid> you know what is missing?
15:29:39 <quaid> dneary: can you file a new ticket to request the rename of arch@ to devel@ (iirc that was the final, but maybe you remember better)
15:29:59 <quaid> and I'll get that one after the MediaWiki (and before we move Mailman)
15:30:17 <quaid> #action dneary to file a new ticket requesting the rename of arch@ to devel@
15:30:31 <quaid> the consent of silence :)
15:30:41 <ewoud> I have a ticket open to write the how to write tickets ticket
15:30:55 <quaid> heh, yep
15:30:55 <dneary> quaid, Yes
15:30:57 <ewoud> but what do we need and how much is self explanatory?
15:31:07 <dneary> I'll open a ticket if it's useful
15:31:38 <quaid> #info how-to write ticket doc could point to existing Fedorahosted.org how-to content on Fedora Wiki - getting an account, etc.
15:31:47 <quaid> #info how-to can also point to Trac docs for more details
15:32:05 <ewoud> good idea
15:32:08 <quaid> #idea how-to could be as straight-forward as five steps
15:32:21 <dneary> Hmmm
15:32:27 <dneary> What account do I use?
15:32:34 <quaid> #info mainly (I think) we want to explain how to use the special fields we set - milestone, priority, component (especially)
15:32:36 <ewoud> fedora account system
15:32:44 <quaid> dneary: Fedora Account (FAS)
15:32:57 <ewoud> I think #8 can be closed now (the github mirror)
15:32:59 <dneary> quaid, I hope they have username/password reminders
15:33:07 <quaid> Step 1: If you don't have a Fedora account user, obtain one :)
15:33:08 <quaid> dneary: yes
15:33:27 <quaid> ewoud: I haven't seen my email this morning, did someone reply to my request to check the work?
15:33:37 <ewoud> quaid: I think I've seen it
15:33:43 <ewoud> will reply that it looks good
15:34:07 <quaid> ok, thx
15:34:09 <dneary> hehe
15:34:21 <dneary> "Security question: What is your password?"
15:34:29 * dneary hates security questions
15:34:31 <quaid> ha!
15:34:36 <quaid> sounds like you set yourself
15:34:50 <quaid> ok, I think that's all for now, the other open tickets have their own agenda topic
15:35:04 <quaid> #topic Puppet & Foreman
15:35:11 <quaid> https://fedorahosted.org/ovirt/ticket/6
15:35:26 <quaid> the goal is to setup the new hosts using Puppet
15:35:49 <quaid> based on nothing but a wild guess, I think it's going to be a few weeks until we need Puppet to be able to do that
15:36:07 <quaid> #info about 2 weeks or more until we need Puppet to manage new incoming hosts
15:36:39 <quaid> #idea setup initial Puppet master on linode01, then move to one of the other hosting VMs when setup by having Puppet replicate itself
15:37:07 <quaid> ewoud: what do we need to do in preparation?
15:37:08 <ewoud> 1 what are the specs of linode01 and can it run puppet+foreman?
15:37:22 <quaid> heh, probably not as-is
15:37:37 <dneary> quaid, I did
15:37:39 <quaid> it has 768 MB RAM
15:38:11 <quaid> dneary: I did that recently, I got back my own question, "What are you registering for?" and now have to guess what the heck I was thinking
15:38:12 <ewoud> I have a server where I'll build a PoC VM
15:38:35 <quaid> ok, is it exposed publicly? would you prefer to make it the master for now?
15:38:49 <ewoud> I can expose it publicly
15:39:26 <ewoud> I'd prefer deciding the final situation later
15:39:31 <quaid> ok
15:39:36 <ewoud> first build a PoC, then see what everyone thinks
15:39:57 <quaid> ok
15:40:06 <quaid> is there any homework the email list can be doing?
15:40:16 <quaid> i.e. talking about package manifests, firewall settings, etc.?
15:40:37 <ewoud> giving my experience and the rest here I think I'll base it on CentOS
15:40:44 <quaid> +1
15:41:10 <ewoud> sec, I'll copy some links from our wiki
15:41:26 <ewoud> #link http://docs.puppetlabs.com/learning/
15:41:30 * quaid approves not just because he's a fan of the technology but because it makes sense based on Infra team makeup - when we get sysadmins with experience in other distros, we can figure how to expand there later
15:41:42 <dneary> quaid, mailman is very slow today (archives links)
15:42:05 <ewoud> #link http://docs.puppetlabs.com/puppet/2.7/reference/lang_visual_index.html
15:42:13 <ewoud> #link http://docs.puppetlabs.com/puppet/2.7/reference/modules_fundamentals.html
15:42:29 <ewoud> #link http://docs.puppetlabs.com/guides/language_guide.html
15:42:35 <ewoud> #link http://docs.puppetlabs.com/references/2.6.17/type.html
15:42:44 <ewoud> I think that should be enough pointers on documentation for now :)
15:42:58 <quaid> great :)
15:43:06 <ewoud> first should be your starting point :)
15:44:17 <quaid> #action Interested Infra team should read related documemtation
15:46:25 <quaid> ok, anything more here?
15:47:46 <quaid> #topic Jenkins
15:48:09 <quaid> I haven't seen RobertM chime in this morning, are you about?
15:48:52 <quaid> #info move of Jenkins Master is dependent on closing hosting arrangements with Alter Way
15:48:59 <RobertM> quaid, I am although Hurricane Sandy is keeping me busy.
15:49:17 <quaid> RobertM: word brother, keep your head down
15:49:48 <quaid> #idea upcoming "excess" VMs can be used for Jenkins slaves, we can start considering how to expand here
15:49:54 <RobertM> I personally have a genny so I will be fine more worried about some of my sites that don't
15:50:13 <quaid> RobertM: did you see the email last week rounding up the 3 hosting initiatives underway
15:51:11 <RobertM> quaid, Sorry my company is in it silly session we do a lot of stuff with elections so I have been putting in 70 / 80 hour work weeks and zero free time.
15:52:32 <quaid> RobertM: no worries, that will be over sometime
15:52:37 <quaid> thanks for the heads up
15:53:00 <quaid> RobertM: about the time we have a closed election will be when we're ready to move Jenkins around, so maybe the timing will be perfect
15:53:30 <quaid> ok, moving on
15:53:34 <quaid> #topic Gerrit
15:53:43 <quaid> anything here?
15:53:52 <quaid> #info git repos are now mirrored on github.com
15:54:09 <quaid> https://github.com/ovirt
15:56:00 * ewoud sent a reply about renaming https://github.com/oVirt/Node to ovirt-node
15:56:14 <ewoud> since Node already has forks, but should be named ovirt-node
15:56:32 <quaid> good, thanks
15:56:54 * quaid closing the ticket
15:57:19 <quaid> ok, moving on ...
15:57:34 <quaid> #topic Any other business in last few minutes?
15:59:53 * ewoud is good
16:01:42 <dneary> quaid, FYI, that ticket is open now
16:01:51 <dneary> I'm also about to open a second re Mailman speed
16:02:08 <dneary> I don't know why, but clicking an archives link takes ~1 minute to render the page
16:03:21 <quaid> hmm, probably Linode being busy
16:03:30 <quaid> ok, closing the meeting ...
16:03:39 <quaid> #endmeeting