14:00:21 <mburns> #startmeeting oVirt Weekly Sync
14:00:21 <ovirtbot> Meeting started Wed Oct 10 14:00:21 2012 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:21 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:28 <mburns> #topic Agenda and roll call
14:01:06 * dustins here
14:01:08 <ovirtbot> 14[[07Meetings14]]4 !10 02http://wiki.ovirt.org/w/index.php?diff=4688&oldid=4613&rcid=4803 5* 03Mburns 5* (+174) 10/* 2012 */ add 2012-10-10 meeting minuts
14:01:28 <mburns> Agenda:
14:01:35 <mburns> Status of Next Release
14:01:35 <mburns> Sub-project reports (engine, vdsm, node, infra)
14:01:36 <mburns> Workshops
14:02:09 * sgordon here
14:02:13 * quaid here
14:03:08 * mgoldboi here
14:03:12 * oschreib here
14:03:24 <mburns> #chair quaid oschreib
14:03:24 <ovirtbot> Current chairs: mburns oschreib quaid
14:03:50 * doronf here
14:03:59 <mburns> #topic Release Status
14:04:03 <mburns> #link http://wiki.ovirt.org/wiki/OVirt_3.2_release-management
14:04:24 <mburns> #info Beta/Feature Freeze target:  Nov 14
14:04:31 <mburns> #info GA Target:  Dec 12
14:04:48 <mburns> #info Test Day target: Nov 19
14:05:04 * jb_netapp here
14:06:00 <mburns> #info all features that i know about are listed on the 3.2 release management page linked above
14:06:39 <mburns> we need to work out release criteria
14:08:19 <mburns> we should start from http://wiki.ovirt.org/wiki/OVirt_3.1_release_management and add things
14:09:22 * mburns proposes some additions
14:09:29 <mburns> 1.  MUST have updates docs
14:09:36 <mburns> 2.  MUST have release notes
14:10:03 <mburns> 3.  MUST work with gluster storage domains
14:10:26 <oschreib> mburns: about 3 - we should see with devel if it's really possible
14:10:46 <mburns> oschreib: iiuc, it worked with 3.1
14:11:30 <oschreib> might have
14:11:32 <oschreib> just saying
14:11:48 <oschreib> not sure it's a release blocker.
14:13:21 <ovirtbot> 14[[07OVirt 3.2 release-management14]]4 !10 02http://wiki.ovirt.org/w/index.php?diff=4689&oldid=4687&rcid=4804 5* 03Mburns 5* (+1235) 10/* Release Criteria */ add some conditions
14:13:47 <mburns> oschreib: ok, some might argue, but we can put it under SHOULD
14:14:12 <sgordon> let's be specific about updates docs
14:14:21 <sgordon> i think we mean the quick start guide jbrooks created on wiki here
14:14:21 <ovirtbot> 14[[07OVirt 3.2 release-management14]]4 !10 02http://wiki.ovirt.org/w/index.php?diff=4690&oldid=4689&rcid=4805 5* 03Mburns 5* (-13) 10/* Release Criteria (DRAFT) */ 
14:14:29 <oschreib> so, why it's under MUST now?
14:14:29 <sgordon> we should work to ensure it is updated pre-release
14:14:40 <mburns> oschreib: just moved it
14:15:24 <mburns> sgordon: don't we have an installation guide too?
14:15:41 <sgordon> we do, but it's basically the RHEV 3.0 installation guide
14:15:58 <sgordon> i think it would be more achievable for now if we pool efforts into the quick start guide
14:16:18 <mburns> sgordon: ok, quick start guide is must
14:16:27 <mburns> updated installation guide is should ?
14:16:43 <sgordon> since jbrooks has gone to the trouble of "ovirtizing" it much more thoroughly
14:16:44 <sgordon> yes
14:17:21 <mgoldboi> mburns: what's the definition of should - does it have any real power?
14:17:30 <sgordon> it gets considered
14:17:38 <sgordon> should can become must depending on how close it is
14:17:55 <sgordon> we wouldn't wait a month for a "should" item
14:18:01 <sgordon> but we might wait a week
14:18:01 <sgordon> etc
14:18:17 <mburns> mgoldboi: in general, we don't block on "should", but we should concentrate on things in the "should" list before things that aren't in the should or must list
14:18:19 <sgordon> it just makes sure it's noted for discussion based on the circumstances at the go/no-go
14:18:36 <ovirtbot> 14[[07OVirt 3.2 release-management14]]4 !10 02http://wiki.ovirt.org/w/index.php?diff=4691&oldid=4690&rcid=4806 5* 03Mburns 5* (+71) 10/* Release Criteria (DRAFT) */ 
14:18:38 <sgordon> that is a more articulate way of stating it ;)
14:18:50 <sgordon> (so tl;dr: what mburns said)
14:19:12 <mburns> sgordon: your point of us waiting on a "should" feature is good too
14:19:21 <mburns> we might wait a few days, but probably not a month
14:19:25 <mgoldboi> sgordon: what about regressions from 3.1 should it go into "should" or "must"?
14:19:40 <mburns> IMO, that's a must
14:19:43 <sgordon> i think regressions should really be must
14:19:50 <sgordon> and flagged as blockers
14:20:08 <ovirtbot> 14[[07OVirt 3.2 release-management14]]4 !10 02http://wiki.ovirt.org/w/index.php?diff=4692&oldid=4691&rcid=4807 5* 03Mburns 5* (+45) 10/* MUST */ 
14:21:02 <sgordon> have we had any more discussion around what is actually required at feature freeze?
14:21:03 <mburns> add attached to the release tracking bug
14:21:10 * sgordon is angling for an actual list of features that made it...
14:21:37 <mburns> sgordon: i think that's a reasonable request
14:21:53 <oschreib> mburns: do we have a tracker bug already?
14:21:58 <mburns> oschreib: not yet
14:22:03 <oschreib> I'll create it
14:22:09 <sgordon> the problem last time was we had an abundance of feature pages but no way to determine which ones were actually finished
14:22:29 <sgordon> itamar did his best to give me a list but even that contained question mark items
14:22:46 <quaid> are we using the "move the feature page to a [[Category:Feature finished]]" method?
14:23:08 <sgordon> quaid, that is what i was thinking yes - a little more onus on the feature owners confirming where they are up to
14:23:20 <quaid> +1
14:23:51 <sgordon> doesnt have to be much more than that, most of the pages were quite thorough in explaining the actual feature
14:23:57 <sgordon> just couldnt tell whether they were done or not
14:24:06 <mburns> step 1 is getting feature pages created
14:24:52 <mburns> #action mburns to work with maintainers to get feature pages created
14:25:01 <mburns> do we have a template feature page anywhere?
14:26:01 <sgordon> mburns,  http://wiki.ovirt.org/wiki/Detailed_feature_template
14:26:12 <sgordon> and, http://wiki.ovirt.org/wiki/Feature_template
14:26:15 <mburns> #link http://wiki.ovirt.org/wiki/Detailed_feature_template
14:26:21 <mburns> #link http://wiki.ovirt.org/wiki/Feature_template
14:26:27 <sgordon> not sure why there are two
14:26:31 <sgordon> that should be consolidated
14:26:59 <mburns> yes, i'll look at them after the meeting
14:27:26 <mburns> ack on moving to a finished category...
14:27:39 <sgordon> they are pretty similar, the detailed one just expands on what should be in the description
14:29:07 <mburns> ok, anything else we want to look at from a release criteria perspective?
14:30:28 <mburns> ok, moving on then
14:30:49 <mburns> #topic sub-project status -- node
14:31:03 <mburns> #info new ovirt-node 2.5.2-0.1 posted last week
14:31:17 <mburns> #info this includes new vdsm build to work around the nfs issue
14:31:50 <mburns> #info as for 3.2 -- we're working on some new features (some captured on the release page)
14:32:25 <mburns> #info most work is behind the scenes to make things more stable/reliable/extensible
14:32:50 <mburns> #topic sub-project status -- vdsm
14:33:00 <mburns> #info new vdsm build posted to work around the nfs issue
14:33:08 <mburns> danken: fsimonce:  any other updates?
14:33:15 <mburns> any work for 3.2?
14:33:57 <fsimonce> mburns, not on my side, I'm wrapping up few other things unrelated to 3.2
14:34:21 <mburns> fsimonce: ok, thanks
14:34:31 <mburns> #topic sub-project status -- engine
14:35:01 <mburns> itamar: doronf:  any updates on 3.2?  status updates?
14:36:32 <ovirtbot> 14[[07Detailed feature template14]]4 !10 02http://wiki.ovirt.org/w/index.php?diff=4693&oldid=2187&rcid=4808 5* 03Quaid 5* (+76) 10addiing gently admonition to not use fake-nesting e.g. "Feature/Your feature name"
14:37:24 <mburns> #info no updates from engine team
14:37:34 <mburns> #topic sub-project status -- infra
14:37:41 <mburns> quaid: RobertM:  updates?
14:38:12 <mburns> #info new infra meeting time:  Mondays at 1500 UTC
14:38:56 <ewoud> mburns: I think dneary was busy with bringing the hosting proposal to the board
14:39:25 <mburns> #info hosting proposal submitted to the board for review (Alter Way)
14:39:55 <quaid> oi, sorry
14:40:12 <quaid> #info Infra now using Trac to track team work tasks
14:40:20 <quaid> http://fedorahosted.org/ovirt
14:40:30 <mburns> board members who are here, can you please review/ack the Alter Way proposal on board@ list?
14:40:38 <quaid> #info Infra team will write up some documentation, etc. on how to report tickets, as well as how we do our own workflow
14:40:57 <quaid> +1 about Alter Way proposal, response soonest is much appreciated
14:41:12 <ovirtbot> 14[[07Infrastructure team meetings14]]4 !10 02http://wiki.ovirt.org/w/index.php?diff=4694&oldid=4664&rcid=4809 5* 03Ekohl 5* (+80) 10Add a link to the minutes from 2012-10-09
14:41:23 <jb_netapp> mburns: will do
14:41:30 <mburns> jb_netapp: thanks!
14:41:35 <quaid> #info We'll get a basic hosting agreement from Alter Way and have that reviewed by Red Hat Legal
14:42:46 <quaid> #info working on MediaWiki upgrade so we can apply new skin and run it on OpenShift
14:42:58 <quaid> s/skin/theme/
14:43:18 <quaid> #info We'll be using Puppet/Foreman to roll out new hosts on new hosting
14:43:42 <quaid> #info New hosting will provide 2 bare metal servers: one for just Jenkins master, one to hold a few VMs that include Gerrit & Mailman
14:44:06 <quaid> #info Migration schedules will be discussed on developer mailing list
14:44:31 <quaid> #info Infra will be renaming arch@ => devel@ (iirc) ideally this week
14:44:45 <quaid> I think that's all :)
14:45:57 <mburns> quaid: excellent update, thanks
14:46:13 <mburns> #topic Workshop -- Bangalore
14:46:36 <mburns> iirc, this is dneary organizing it, right?
14:46:41 <lh> mburns, correct
14:47:53 <mburns> mgoldboi: did the live iso get posted?
14:48:08 <mgoldboi> mburns: making final changes
14:48:14 <mburns> mgoldboi: ok, thanks
14:48:20 <mgoldboi> mburns: will be up there in a couple of hours
14:48:29 <mburns> #info live oVirt iso being finalized by mgoldboi now
14:48:39 <mburns> #info should be posted to ovirt.org in a few hours
14:48:48 <mburns> dneary: any other updates?
14:49:10 <mburns> guess that's a no....
14:49:20 <mburns> ok, we'll skip to Barcelona instead
14:49:27 <mburns> and come back if Dave comes back online
14:49:36 <mburns> #topic Workshops -- Barcelona
14:49:38 <lh> mburns, I'll have an update on attendee #s for Barcelona later today
14:49:54 <mburns> #info update on # of attendees coming later today
14:50:15 <mburns> lh: any updates on schedule?
14:50:16 <lh> oVirt will be exhibiting in booth #22 in Barcelona
14:50:18 <lh> http://go.linuxfoundation.org/lceu_elce12_sponsor_guide
14:50:29 <lh> mburns, my understanding is that the schedule should be published this week
14:50:43 <lh> mburns, but all speakers have been notified of talk acceptance
14:50:56 <mburns> #link http://go.linuxfoundation.org/lceu_elce12_sponsor_guide
14:51:00 <aglitke> I would like to ask about the speaker attendance code.  I assume I will be speaking at the conf but I have still not heard anything.
14:51:15 <lh> If folks require letters for visas to attend, they should speak with the Linux Foundation for an invitation. I can put folks in touch with the right people at LF.
14:51:16 <mburns> lh: yes, i haven't heard approval for speaking yet either...
14:51:20 * jbrooks is ready to promote agenda when it's available
14:51:31 <lh> mburns, aglitke ok, this is a new data point for me. i will follow up on this matter.
14:51:40 <mburns> #info schedule should be published later this week
14:51:54 <lh> my understanding is that your speaker registration details will be included in notification that your talk was accepted
14:51:54 <mburns> aglitke: there will be a code in the notification email
14:52:00 <aglitke> I guess we just need the "Your topic has been approved, please register with this code" email
14:52:07 <mburns> aglitke: yep
14:52:37 <mburns> #info if you need a visa to attend, please talk to the linux foundation for an invitation
14:52:43 <lh> as jbrooks mentioned, he's on deck to help us promote the event as soon as the schedule is published
14:53:07 <lh> dneary will be helping with promotion as well, and the linux foundation folks have committed to promoting in their newsletters when the schedule is published
14:53:22 <lh> only other note i have is to ping mburns re: demo in the booth
14:53:37 <mburns> #info dneary and jbrooks will be helping with promoting the workshop as soon as we have a schedule
14:53:43 <lh> mburns, any update on that? i got us an end cap booth in case we need more room for demo equipment
14:53:57 <mburns> lh: looks like we're going to be demoing from a  laptop
14:54:09 <mburns> logistics were too difficult to get hardware donated
14:54:23 <lh> mburns, excellent, then we are all set. our booth has an integrated display so we can simply hook up the laptop and be good to go.
14:54:30 <lh> mburns, no worries, we're still in a fine location.
14:55:03 <lh> mburns, that's all i have on barcelona. dneary may have more to add and have an update on bangalore
14:55:10 <mburns> #info demo at the booth will be from a laptop, real hardware was too difficult to get
14:55:28 <mburns> dneary: do you have updates on bangalore?
14:57:46 <mburns> ok, guess not
14:57:51 <mburns> #topic other topics
14:57:58 <mburns> anyone have anything else today?
14:59:12 <mburns> going once...
14:59:28 <mburns> twice..
15:00:19 <mburns> gone.
15:00:23 <mburns> #info no other topics
15:00:27 <mburns> Thanks all!
15:00:30 <mburns> #endmeeting