14:07:13 <mburns> #startmeeting oVirt Weekly Sync
14:07:13 <ovirtbot> Meeting started Wed Sep  5 14:07:13 2012 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:07:13 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:07:13 <lh> quaid, ^5
14:07:15 * quaid was late too
14:07:29 * dustins here
14:07:33 <mburns> #topic agenda and roll call
14:07:34 * lh is here
14:08:23 <mburns> Agenda:  Status of Next Release (Release Criteria, Target GA date)
14:08:23 <mburns> Sub-project reports (engine, vdsm, node, infra)
14:08:23 <mburns> Workshops
14:08:23 <mburns> New web site design
14:08:36 * sgordon is here
14:08:57 <jb_netapp> /me here
14:09:15 * jb_netapp here
14:09:27 * garrett_ is here
14:09:57 * mburns apologizes for late start -- rebuilt laptop is apparently not getting meeting reminders...
14:10:07 * RobertM here
14:10:15 <mburns> #topic Next Releaes
14:10:35 <mburns> #topic Next Releae
14:10:38 <mburns> #topic Next Release
14:10:42 <mburns> bah...
14:10:52 <mburns> ok, so next release
14:11:07 <mburns> do we have the right people here to talk about it today?
14:11:07 <dneary> Hi
14:11:12 <dneary> I'm here
14:11:15 <mburns> someone from engine and vdsm teams?
14:11:16 <dneary> Sorry I missed roll call
14:12:22 <mburns> abaron: doron:  around to discuss next release?
14:13:19 <dneary> Hmmm... this is getting a bit ridiculous.
14:13:46 <dneary> I guess it's the problem with weekly meetings - it is easy to miss one, and once you've missed one, it's easy to miss a second one...
14:14:31 <dneary> Perhaps we need to abandon weekly meetings, and only have meetings when there's a need (like release planning, go/no go, or when something comes up that requires one)
14:14:37 <mburns> #action mburns to track down maintainers and get agreement on dates and feature set for next release
14:14:49 <sgordon> mmm i think that's dangerous, really they should be here
14:14:53 <mburns> dneary: what we need is a project manager
14:15:00 <mburns> that's empowered in the project
14:15:30 <mburns> #action mburns to propose new role in the project
14:15:44 <jb_netapp> mburns: +1
14:15:54 <lh> mburns, jb_netapp +1
14:16:01 <mburns> i'd propose it here, but there's no one here to vote on it
14:16:13 * mburns will take it to board list
14:16:33 <mburns> ok, so no real reason to continue discussing the fact that we can't discuss the release
14:16:35 <dneary> mburns, Let me send an email to arch@ to let people know we have a meeting now - in the meantime, who is here to talk about teh website?
14:16:37 <sgordon> i +1 it but then im not board ;)
14:16:53 <mburns> sgordon: i'm not either
14:17:04 <mburns> in fact only board member here i think is jb_netapp
14:17:19 <sgordon> yeah
14:17:24 * jb_netapp nods
14:17:48 <mburns> #info no one here so no reason for sub-project reports or release status updates
14:17:52 <sgordon> i have some thoughts on the delivery stuff, not sure if jbrooks is around because he had been looking at this too
14:17:55 <mburns> #topic infra report
14:18:00 <sgordon> (or at least a quick start vm script)
14:18:03 <mburns> quaid: RobertM:  any updates?
14:18:14 <quaid> um
14:18:27 * lh has to step afk, brb
14:18:31 <quaid> we need new hosting and are working on that - short term and long term
14:19:00 <mburns> #info need new hosting, working on plan for both short and long term
14:19:09 <RobertM> quaid, Not really other then the fact the jenkins.ovirt.info is offline because a recent update took Jenkins offline.
14:19:25 <quaid> #info Infra team  is likely to takeover the Trac instance on fedorahosted for the time being
14:19:47 <quaid> RobertM: sorry, not really? what?
14:20:15 <mburns> #info for those unaware, this trac instance was used by ovirt-node team prior to relaunch of the project a year ago
14:20:19 <quaid> and we talked with garrett about the reasons to unify content management under one, single themable tool (MediaWiki) instead of two (MW + WordPress)
14:20:26 <RobertM> quaid, Last night and ran Yum upgrade and it pulled in new versions of java and things broken all over the place.
14:20:28 <dneary> mburns, Don't say there's no-one here, you'll hurt my feelings (and yours, and sgordon's, ad...)
14:20:49 <dyasny> quaid, so when will there be a new site up, running on MW?
14:20:49 <mburns> dneary: so meant no maintainers
14:20:56 <dneary> mburns, I know :)
14:20:59 <quaid> #info Infra is ready to implement whatever website solution is decided above our level
14:21:06 * mburns can't type today
14:21:09 <mburns> s/so/sorry
14:21:13 <dneary> mburns, But it's good to make people aware that there were other people here...
14:21:26 <quaid> dyasny: first, the Board people need to get engaged in the new design discussion ASAP ... then when they decide, we implement
14:21:50 <mburns> #info correction -- no code sub-project maintainers around, there are other people around (and infra maintainers are here)
14:21:53 <dneary> I admit, I'm lukewarm to the idea of a MediaWiki only site
14:22:04 <garrett_> dneary, what are the reasons?
14:22:13 <quaid> careful, topic jump!
14:22:16 <RobertM> dneary, I am cold to the idea.
14:22:28 <dyasny> quaid, is there a list of people posted somewhere?
14:22:38 <mburns> ok, are we done with infra update?
14:22:44 <mburns> and ready to jump to website?
14:22:44 <garrett_> (okay, let's say that some people have concerns and discuss the concerns later, then)
14:22:48 <dneary> garrett_, attractive MediaWiki sites are very rare, and maintaining the attractive front-page & section pages is a lot of work up-front, and kind of tricky afterwards
14:22:51 <quaid> dyasny: http://www.ovirt.org/governance/board/
14:23:03 <mburns> #topic website design
14:23:07 <garrett_> dneary, there's no reason why we cannot have an attractive MediaWiki site
14:23:25 <mburns> #info discussing pros/cons to moving completely to mediawiki
14:23:29 <dneary> garrett_, Also, integrating things like RSS feeds, embedded media, etc - which tyou really want in a website - are a bit trickier to handle in a secure way on MW
14:23:31 <garrett_> I'm confident that I can make it attractive and _not_ look like a wiki
14:23:56 <mburns> can we lock down certain pages to only allow certain people to update?
14:24:02 <quaid> yes
14:24:02 <garrett_> mburns, yes
14:24:05 <dneary> mburns, Yes, that's possible
14:24:10 <mburns> ok
14:24:17 <sgordon> tbh i dont have an issue with it
14:24:25 <dyasny> quaid, thanks
14:24:35 <dneary> mburns, It's trickier to have certain pages which don't have the standard wiki sidebar and header, though - that requires working directly with the MW theme
14:24:39 <mburns> that's my main objection -- i don't think we want everyone to be able to update the home page
14:24:46 <garrett_> right
14:24:55 <quaid> I'm concerned about ecosystem - WordPress has lots of extensions to do all sorts of magic, MW seems to have more focused on wiki-ness
14:25:02 <garrett_> we don't want people updating the home page or the section main pages
14:25:07 <dneary> mburns, Which requires admin access to the server (and thus, you lose some of the benefits of having a wiki - namely, that anyone can make changes
14:25:08 <garrett_> unless they're allowed to
14:25:26 <quaid> I'm not so sure it matters to lock down those pages, to be honest
14:25:32 <garrett_> quaid, please identify the magical extensions that we'd use
14:25:37 <sgordon> i think it is
14:25:40 <dneary> quaid, I'm happy having them locked down
14:25:48 <sgordon> you have to have some lock down on stuff like that
14:25:51 <quaid> we don't get spammers, so any edits will be honest mistakes, easyt to fix
14:26:02 <quaid> I'd rather people not feel locked out and enabled to fix stuff, but no biggie
14:26:14 <dneary> Wiki gardening gets a lot more onerous (and I admire your confidence re spammers!) when the full site is under the wiki
14:26:25 <quaid> garrett_: JetPack, for one - site stats, Akismet
14:26:32 <sgordon> yeah i agree with your sentiment there dneary
14:26:37 <dneary> garrett_, That said, I do not doubt your ability to come up with an attractive un-wiki-like wiki front page
14:26:43 <sgordon> if we are in any way successful as a project the spammers will eventually come
14:26:46 <quaid> garrett_: it has RSS feeds built in so e.g. right side feed is created
14:26:49 <dneary> But I think it'll be a lot more work than doing it in Wordpress
14:26:58 <dneary> An just doing an oVirty theme for MediaWiki
14:26:59 <garrett_> we do have a problem of where to put the content, how to edit it, and how to find it via search
14:27:10 <quaid> as bad as  http://www.ovirt.org/community-activity is, I don't see how we'd do that with MW
14:27:13 <dneary> garrett_, Search is a real issue
14:27:15 <garrett_> quaid, yeah, but the RSS feeds are generally not so useful
14:27:23 <sgordon> garrett_, that is a more general problem with our wiki layour
14:27:23 <RobertM> Search isn't that hard to fix.
14:27:25 <sgordon> *layout
14:27:26 <garrett_> at least currently on oVirt.org
14:27:30 <sgordon> not just for what you are trying to do
14:27:42 <RobertM> Both media wiki and wp support using google or
14:27:44 <garrett_> and I know MW does have RSS stuff too
14:28:14 <quaid> garrett_: RSS fees not useful? which ones?
14:28:36 <dneary> quaid, The wiki edits one isn't very useful
14:28:37 <quaid> garrett_: our wiki has incorrectly named pages, fwiw, which makes searching it harder
14:28:48 <garrett_> quaid, most of them, really
14:28:49 <dneary> quaid, which incorrectly named pages?
14:28:53 <garrett_> at least for most viewers of the site
14:28:55 <sgordon> well tbh i dont see how the rss feeds for patches
14:28:57 <garrett_> right now, how they're structured
14:29:01 <quaid> dneary: agreed, MW RSS feeds are not so great IME; also, the lack of sending an email with each page edit has long bugged me
14:29:04 <sgordon> are any more meaningful that a patches list
14:29:21 <garrett_> quaid, people don't search for the arbitrary titles of pages, though
14:29:22 <sgordon> nobody just browsing cares about individual patches
14:29:28 <garrett_> exactly
14:29:32 <sgordon> just one date 'last commit' to show it is being updated
14:29:34 <quaid> garrett_: the current site doesn't have any meaningful RSS outside of th eoccasional blog post, and all the community activity stuff
14:29:42 <sgordon> would fulfil the same person
14:29:45 <sgordon> *purpose rather
14:29:49 <garrett_> not really
14:29:59 <quaid> garrett_: it's not arbitrary, a page should be named properly - the problem is fake/nesting/doesn't/search/well, and poeple using STudlyCaps
14:30:00 <garrett_> it's some meaningless garbage to most people viewing the site
14:30:05 <garrett_> it's useful to developers sometimes, sure
14:30:14 <garrett_> but there are other places for developers to see that
14:30:15 <quaid> so to use MW, we need a seriously deep and wide gardening effort
14:30:18 <sgordon> but then developers are usually on patches lists
14:30:20 <quaid> and teach people and enforce the teaching
14:30:23 <sgordon> for their projects
14:30:31 <dneary> We seem to have 3 conversations going at once at the moment
14:30:32 <garrett_> quaid, yes, but I'm saying that people don't search for *titles* of web pages
14:30:35 <sgordon> especially with gerrit spamming notifications if you watch them as well
14:30:49 <dneary> I suggest that garrett_ take the lead and we do one topic at a time for this discussion.
14:31:02 <garrett_> I think we need to step back from the implementation discussion right now
14:31:10 <garrett_> and first state what we want in a website
14:31:21 <quaid> garrett_: proper page naming helps, though, in that it's supposed to be descriptive of the page contents, and that does hit search terms
14:31:25 <garrett_> and then, later match up the technology with that
14:31:41 <garrett_> I'm not a huge fan of MediaWiki, really
14:31:49 <quaid> there's one problem with that approach, though
14:31:50 <garrett_> I hate the syntax and some of its cruftiness
14:31:58 <quaid> if you want a wiki, you want MediaWiki
14:31:59 <garrett_> I'm only suggesting it because we do need a unified place to put the content
14:32:04 <quaid> so the technology answers the question
14:32:06 <garrett_> and I think a wiki works well for our purposes
14:32:21 <garrett_> quaid, exactly why I suggested MediaWiki
14:32:35 <quaid> it's just that we can talk all day about what we want in a website
14:32:38 <quaid> but if it's wiki, that means MW
14:32:43 <garrett_> I did look into some others, such as Gollum, today, but it won't work for what we need, sadly
14:32:45 <quaid> and if you want to drive us to one tool, that means MW
14:32:55 <garrett_> right
14:33:01 <quaid> it's a bit of a foregone conclusion, based on just those criteria
14:33:01 <garrett_> exactly
14:33:05 <garrett_> yup
14:33:25 <garrett_> I think all of us have issues with MediaWiki, but it's pretty much what we need to use
14:33:27 <mburns> ok, back up for a second
14:33:35 <mburns> are we all committed to a single tool?
14:33:45 <garrett_> yes, for the general website
14:33:46 <mburns> or are there serious objections to a single tool
14:33:50 <dneary> quaid, The "one tool" thing is, I think, implementation detail
14:34:13 <garrett_> it doesn't make sense to have to places to put the same stuff
14:34:14 <RobertM> mburns, I really don't like the idea at all
14:34:21 <garrett_> and then to retheme both to work the same
14:34:22 <dneary> garrett_, Would much prefer to come back to that later
14:34:25 <mburns> RobertM: what specific objections do you have?
14:34:41 <dneary> garrett_, We could spend all day debating tools, and not get to th website at all
14:34:41 <garrett_> and different ways to write content depending on where stuff goes
14:35:01 <garrett_> dneary, the only tools we're talking about are WP vs MW
14:35:07 <RobertM> To me there a separation between the main site and a wiki.
14:35:13 <dneary> Or WP+MW (my preference)
14:35:14 <garrett_> are we going to drop MediaWiki and go to WordPress only?
14:35:28 <garrett_> RobertM, or the main site and a blog
14:35:38 <cctrieloff> RobertM: To me there a separation between the main site and a wiki.   -- do you see a separation as good or bad?
14:35:41 <garrett_> to me, that's a more logical separation
14:35:56 <garrett_> and probably to most
14:35:58 <RobertM> cctrieloff, I see the separtion as good.
14:36:10 <sgordon> as a user reading the content i think it sets expectations differently
14:36:49 <RobertM> There is a diff between what the project is tring to tell new people and returning people that don't following the project daily and what someone posts in a wiki.
14:36:58 <garrett_> that any content on the wiki is probably outdated and not official?
14:37:04 <dneary> garrett_, I think that what you and quaid said earlier is probably true - first we need to decide what we want the site to be/say/do, and the technology choices will probably fall out of that
14:37:09 <garrett_> (that's what I think when I see a wiki styled like a wiki)
14:37:37 <mburns> RobertM: could you get behind using mediawiki for the main site if it's locked down and mostly static content
14:37:53 <mburns> essentially, move the content from wordpress into locked down pages that don't look wiki-ish
14:38:02 <garrett_> dneary, right, and that's why I worked hard on the design (it's more than just the look and feel)
14:38:08 <sgordon> garrett_, basically yes - and even when they are not styled as wikis (cough, libvirt.org i am looking at you) i usually find those expectations accurately
14:38:12 <sgordon> *accurate
14:38:37 <RobertM> mburns, I think as sgordon said there is a diff set of expectations based on a wiki ver a website.
14:38:41 <dneary> garrett_, I think we can do a more attractively styled wiki, with a similar style to the front pages, even when they're using a different tool, with less work than doing custom pages for the front
14:39:11 <sgordon> my concern is how stuff like what dyasny is planning for vdsm hooks will fit into a MW site
14:39:13 <garrett_> dneary, so we do static HTML for the standard pages then? or?
14:39:25 <sgordon> stuff where the content is in fact somewhat dynamic
14:39:34 <quaid> sgordon: I don't think it will fit, but then it wasn't fitting in to WP very well either
14:39:38 <garrett_> because you have to do a lot of jumping through hoops to get things styled up exactly how you want it regardless of WP or MW
14:39:49 <quaid> sgordon: I think we may be looking at a new solution for plugins.ovirt.org, sadly
14:39:53 <dneary> garrett_, And I am betting that we will want to do more complicated things on the website (platform detection on the downloads page, forms, ratings and user comments for add-ons) than can easily be done in MediaWiki
14:39:54 <garrett_> or at the very least a little bit
14:40:04 <sgordon> quaid, why would we not build that as a WP plugin?
14:40:12 <dneary> garrett_, I'm betting that "making search work for the whole site" is the easier problem to solve
14:40:21 <garrett_> why would we need platform detection?
14:40:22 <dneary> But, again, we're talking about tools, not the site
14:40:23 <quaid> sgordon: who is we that is building stuff for INfra?
14:40:39 <RobertM> dneary, You would be right either use google or something like Apache Solr
14:40:41 <quaid> sgordon: at the moment, we have no PHP hackers, and if we do, do we want to be maintaining our own custom plugin?
14:40:56 <garrett_> we shouldn't talk about hand-wavy we-could-possibly-do-this-or-that sorts of things
14:40:58 * RobertM caughs
14:41:04 <mburns> no need for platform detection....people will be downloading plugins that they need, then pushing the plugins out to their hosts
14:41:06 <garrett_> but talk about what we want to do exactly, at least the basics
14:41:08 <sgordon> quaid, you are telling me you cant find a WP plugin that does exactly whats required or close enough, but you can find a completely separate tool
14:41:11 <quaid> ok, we have one PHP hacker .... sorry RobertM  :)
14:41:17 <dneary> garrett_, Static HTML for the front pages would not bother me in the least :)
14:41:19 <mburns> they're unlikely to be downloading from their hosts directly
14:41:32 <garrett_> dneary, they'd have to be able to be maintained
14:41:34 <dneary> garrett_, As long as the site accomplishes what we want
14:41:46 <quaid> sgordon: I'm just giving a temp reading right now, dyasny hasn't found a plugin that works directly, and said we could write one
14:41:50 <mburns> static pages in the infra git repo (or similar git repo)
14:41:53 <dneary> (which is, I think you'll agree, the most important)
14:42:02 <dneary> garrett_, Yes, agreed.
14:42:13 <quaid> but why static HTML when WP can do that just as easily?
14:42:21 <garrett_> dneary, I was basically using that as an argument that w/ both WP and MW, you have to do brute force to make it render a page like you want
14:42:29 <sgordon> quaid, never mind that maintaining a completely separate platform just for plugins will be about as much extra work for infra as maintaining a wp plugin anyway :p
14:42:39 <garrett_> (we had to copy/paste HTML precisely for the community site to make it look right in WP, for example)
14:42:47 <quaid> sgordon: perhaps, perhaps
14:42:48 <dneary> garrett_, Let's just say that I threw that out there not as a formal proposal, but as my way of saying "the tool only matters in so far as it can do what we want, without much work on our part"
14:43:19 <garrett_> quaid, we don't really need to do static HTML; but we might have to do HTML inside of either WP or MW
14:43:27 <dneary> So it seems to me that this should follow the other discussion
14:43:32 <garrett_> if it's going to be fragile HTML in either system, then the system doesn't matter
14:43:47 <mburns> ok, let's back up for a minute
14:43:59 <mburns> we're getting into too much implementation
14:44:15 <mburns> what are the requiements?
14:44:25 <mburns> 1.  integrated search across main site and wiki
14:44:39 <mburns> 2.  different look/feel to main site and wiki
14:44:51 <mburns> 3.  some method to handle dynamic content like the vdsm plugins
14:44:57 <mburns> anything else?
14:45:05 <garrett_> mburns, #2 isn't the case; I'm arguing that there is no difference, and it should be the same site
14:45:06 <garrett_> I don't want to create multiple sites that work differently, nor do I want to hand off maintenance of multiple different sites to someone else
14:45:13 <sgordon> access control, preferably allowing more editors than currently
14:45:43 <mburns> garrett_: i think we want the main site to look different than the wiki
14:45:44 <garrett_> it's a lot of work just implementing one site properly and making sure it's up to date and working well (security issues, etc.)
14:45:51 <garrett_> mburns, why?!
14:45:52 <sgordon> mburns, +1
14:45:53 <mburns> whether they're the same tool or not, is implementation
14:46:08 <sgordon> same reason i said before, users have different expectations of the content
14:46:09 <mburns> garrett_: i'm just saying what i'm reading...
14:46:09 <garrett_> I don't think that makes any sense
14:46:33 <sgordon> if it all looks like the wiki then users will have the same expectations of it as they do the wiki
14:46:37 <mburns> 4.  limited access to change main site pages
14:46:40 <garrett_> it fragments the content, multiplies the work for us all
14:46:41 <dneary> mburns, 4.  Fulfills the expectations of visitors to the site
14:46:51 <dneary> That one's pretty important!
14:46:52 <mburns> dneary: bad requirement...
14:46:57 <mburns> you need to define expectations
14:46:58 <sgordon> yeahhh
14:46:58 <garrett_> we're not a hosted website product...
14:47:11 <dneary> mburns, Allow me to expand & rephrase
14:47:16 <mburns> dneary: sure
14:47:23 <mburns> #info requirements
14:47:32 <dneary> 4.  Makes it easy to find out about and download oVirt
14:47:37 <mburns> #info 1.  integrated search across main site and wiki
14:47:53 <dneary> 5.  Provides resources to users having difficulty getting started
14:47:55 <mburns> #info 2.  some method to handle dynamic content like vdsm plugins
14:48:13 <mburns> #info 3.  Makes it easy to find out about and download oVirt
14:48:21 <RobertM> mburns, #2 also has to intergrate with #1
14:48:33 <mburns> #info 4.  Provides quickstart guide
14:48:39 <dneary> 6.  Provides a user-friendly gateway to get in contact with the oVirt developers to ask a question, report a bug, see what is planned for the project, or suggest a future improvement
14:48:45 <garrett_> "dynamic content like vdsm plugins" ← how does this relate to the website?
14:49:11 <mburns> #info 4.  access control for some main site pages
14:49:38 <mburns> garrett_: it's a requirement that we be able to support the plugins page
14:49:38 <garrett_> first of all, I'd like to know: has everyone here read my design proposals to the mailing lists, including the messages and mockups?
14:49:41 <sgordon> garrett_, i think it's the first example, i think ultimately we may have virtual appliances as well
14:49:55 <sgordon> so it shouldnt be considered the only case where we might want dynamic content
14:50:04 <dneary> 7.  Provides a valuable resource to new oVirt developers explaining the development processes, architecture and community standards of the projec t
14:50:11 <RobertM> No matter what we do for plug-in they are going to need to be searchable.
14:50:22 <sgordon> virtual appliances will be a fair way down the road though because it raises questions about storage etc..
14:50:32 <dneary> mburns, They might be harder to elaborate, but that's what we want the site to do.
14:50:33 <garrett_> http://people.redhat.com/glesage/oVirt/background-info/design.html
14:50:36 <garrett_> http://people.redhat.com/glesage/oVirt/background-info/design-download.html
14:50:53 <dneary> I could add 8.  Gives a glimpse into the work and life of the oVirt development team
14:50:54 <sgordon> i dont think those sites work the way you expect garrett_
14:50:55 <quaid> garrett_: good to repost the links, thanks - we have to presume people debating here have read the thread(s) so far
14:50:56 <garrett_> the first one is my design for the oVirt website, the second details the concepts behind download page
14:50:57 <sgordon> getting shadowman
14:51:14 <quaid> dneary: add 8, yes
14:51:14 <sgordon> oh nm
14:51:25 <quaid> dneary: 'community activity' stuff has always been one of our popular pages
14:51:41 <dneary> And we'll be adding 9.  Provide oVirt community members with a way to distribute and promote add-ons to the main oVirt project
14:51:46 <mburns> #info 5.  Provides a user-friendly gateway to get in contact with the oVirt developers to ask a question, report a bug, see what is planned for the project, or suggest a future improvement
14:51:48 <garrett_> quaid, right, if people haven't read the background behind it and also have seen the mockups, then I don't understand having the conversation with a lot of hand-waving
14:51:55 <sgordon> i would think user stories might provide more insight
14:51:57 <RobertM> mburns, #1 shoould be integrate search accross all of ovirt.org. There is the mailing list, plugin, etc that are comming online.
14:51:59 <sgordon> than the patch RSS
14:52:13 <quaid> garrett_: right, I'm presuming people have read the background :)
14:52:15 <mburns> #info 6.  Provides a valuable resource to new oVirt developers explaining the development processes, architecture and community standards of the project
14:52:29 <garrett_> the mockups are here: http://people.redhat.com/glesage/oVirt/website/mockup-1/ (and you can click on the navigation, even though it's a static PNG export from Inkscape and not a real page)
14:52:38 <garrett_> quaid, right, but it sounds like some people haven't really
14:52:40 <dneary> mburns, Sorry my numbering got out of sync with yours :)
14:52:43 <mburns> RobertM: yes, integrated search across all is important
14:52:45 <mburns> dneary: np
14:52:57 <mburns> #info 7.  Gives a glimpse into the work and life of the oVirt development team
14:52:57 <RobertM> garrett_, I have seen the mackup and they look nice.
14:53:01 <dneary> garrett_, Is that a fair summary of the requirements you've been working off??
14:53:10 * garrett_ looks up a bit
14:53:13 <mburns> #info 8.  Provide oVirt community members with a way to distribute and promote add-ons to the main oVirt project
14:53:25 <garrett_> dneary, I wrote a bit about it in the emails (which I formatted nicely and linked to just a little bit ago)
14:53:42 <garrett_> it's really hard to read it all mixed up in IRC
14:54:03 <mburns> #info 9.  (debated) main site and wiki are distinct
14:54:06 <quaid> oh, we'll be back in the mailing list soon - nothing we can really decide in IRC
14:54:11 <RobertM> True.  This really needs to be moved to Email.
14:54:23 <mburns> yes, we can take it to the list
14:54:52 <mburns> the summary email will have the 9 requirements we have
14:54:57 <mburns> so we can start from that
14:55:00 <garrett_> I think those are about right?
14:55:04 <dneary> garrett_, I understand
14:55:19 <mburns> i'd like to move on since we know we can't decide right now
14:55:34 <mburns> #topic Workshops
14:55:36 <sgordon> ok
14:55:44 <dneary> Hmmm :(
14:55:47 <mburns> lh: back from afk yet?
14:55:53 <garrett_> it would be nice to actually discuss this
14:56:02 <garrett_> over voice, like in a video conference
14:56:03 * sgordon would like to return to briefly try and discuss the implications for distribution at the end
14:56:05 <lh> mburns, one sec on the phone
14:56:08 <dneary> we were just getting to the interesting bits I wanted to discuss (ie. how well the current mock-ups fulfill the requirements we just stated)
14:56:28 <lh> mburns, and now i am not
14:56:39 <lh> mburns, i have very little to share re: workshops - i can summarize on list easily
14:56:44 <garrett_> dneary, yeah ):
14:56:58 * lh proposes that we table workshop discussion until next meeting
14:57:11 <sgordon> dneary, yeah but i am rapidly running out of caffiene ;p
14:57:13 <lh> mburns, ^^ does this work for you?
14:57:22 <mburns> lh: sure
14:57:26 <lh> mburns, thank you
14:57:40 <mburns> #topic back to website design
14:57:49 <mburns> #chair quaid dneary garrett_ sgordon
14:57:49 <ovirtbot> Current chairs: dneary garrett_ mburns quaid sgordon
14:58:02 * mburns going to be more distracted shortly, so chairing people
14:58:29 <mburns> dneary: garrett_:  go ahead and continue the discussion, but try to capture some of it in #infos
14:58:55 <jb_netapp> mburns: we can table wkshp discussion.. just know that lh and I were discussing a NetApp sponsored workshop in Sunnyvale for January...
14:59:09 <mburns> jb_netapp: good to know
14:59:29 <lh> mburns, and there will be an update sent to list today for all who are here (and are not) :)
14:59:42 * mburns just sent proposal for adding a project manager
15:00:15 <garrett_> (I'd like to note that it's a bit difficult to communicate visual things, and the background behind it all over mailing lists and IRC)
15:00:25 <quaid> yes, but
15:00:37 <dneary> Just to refresh everyone's memory: Links to mock-ups are here: http://people.redhat.com/glesage/oVirt/website/mockup-1/
15:00:46 <dneary> (I know you posted the link 10 mins ago)
15:00:53 <garrett_> and a prerequisite for even taking part of this discussion is to read the emails I sent, and look at the mockups too
15:01:05 <garrett_> http://people.redhat.com/glesage/oVirt/website/background-info/design.html
15:01:25 <garrett_> ^ this is the first email, reformatted nicely, to make it easier to read
15:01:25 <quaid> garrett_: I hear ya, but I resist video/phone calls - ovirt has too many already - let's try to get people engaged on the mailing list - we can't get them in this IRC meeting, can't presume we can schedule them all for a video session
15:01:33 <dyasny> garrett_, so, you will be able to refactor MW to these mockups?
15:01:42 <garrett_> dyasny, yes, I can do that
15:02:00 <garrett_> http://people.redhat.com/glesage/oVirt/website/background-info/design-download.html
15:02:09 <dyasny> garrett_, then I'll need to drag you away for a quick conversation when you're done with this meeting
15:02:19 <garrett_> ^ this details the download page, including some ideas that I think we need to do to make it easier to download and install oVirt
15:02:25 <garrett_> dyasny, okay, sounds good
15:03:01 <garrett_> I would love for everyone to read these and look over (and read) the mockups, if you haven't done so already
15:03:40 <garrett_> http://people.redhat.com/glesage/oVirt/website/background-info/design.html#Front-page%20sections
15:03:47 <dyasny> garrett_, they definitely feel professional
15:04:07 <dneary> "New design RFC" email:  http://lists.ovirt.org/pipermail/infra/2012-August/000871.html and http://lists.ovirt.org/pipermail/board/2012-August/000610.html
15:04:20 <garrett_> ^ that section, in the bulleted list, is basically more-or-less the goals of the front page, which mostly mesh with what was said here in IRC (I think?)
15:04:46 <garrett_> dneary, yep, I reformatted that with some minor changes for easier reading @ http://people.redhat.com/glesage/oVirt/website/background-info/design.html
15:04:59 <dneary> garrett_, Ah - thanks for that, just followed the link as you were re-posting it
15:05:01 <garrett_> but that's where the discussions start in the mailing lists
15:05:13 <dneary> As you mentioned, following a conversation on IRC can be tricky sometimes
15:05:16 <RobertM> garrett_, For the record I like your designs I just hate the idea of making mediawiki the front page.  I have seen project do it and I have never seen one that works well.
15:05:25 <garrett_> so it's a place where people can communicate using the mailing lists
15:05:56 <garrett_> RobertM, I hate the idea of using MediaWiki too, but: 1) we want to have a lot of content that people can edit  2) I can make it work
15:06:17 <garrett_> 3) ...and "make it work" where it doesn't look like MediaWiki too
15:06:35 <dneary> garrett_, In addition to the goals you wrote, the download portal is an extra (newer) requirement
15:06:46 <garrett_> what's the download portal?
15:06:56 <quaid> it does seem that garrett_ is consistently certain he can handle the "but it looks like MW" objection
15:07:07 <cctrieloff> garrett_: do you believe we can make MediaWiki look like the mockups, i.e. that good?
15:07:20 <garrett_> yes, I know enough HTML and CSS, and have themed MediaWiki many, many years ago
15:07:23 <dneary> garrett_, dyasny's working on getting a website where devs can upload add-ons to oVirt, and offer downloads to users.
15:07:23 <garrett_> and it supports themes
15:07:32 <garrett_> cctrieloff, yes, I can make it look like the mockups
15:07:51 <dneary> garrett_, Do you know how much work & time is involved?
15:07:59 <garrett_> we'd have all the wiki stuff turned off, and only show some of the useful parts in a tasteful way when one is signed in
15:08:10 <garrett_> dneary, great question. I don't really know
15:08:10 <cctrieloff> I think that is the main concern, then we should give ti a go.
15:08:25 <garrett_> but it's MUCH less than making it work with both WP and MW
15:08:41 <cctrieloff> the second concern seems the work that dyasny  is doing for add-ons
15:09:09 <cctrieloff> where is that work being done ? WP?
15:09:14 <garrett_> cctrieloff, is that add-ons for oVirt being in a place on the site? or is that add-ons for WordPress and/or MediaWiki?
15:09:17 <dneary> garrett_, Could you do one page, see how long it takes, and we use that data point to decide?
15:09:20 <dyasny> dneary, and that's exactly why I need to drag garrett_ away for a chat
15:09:38 <dneary> dyasny, Colour me surprised ;-)
15:09:42 <garrett_> dneary, not entirely... MediaWiki themes aren't pages (;
15:10:05 <garrett_> but I can start to make a MediaWiki theme
15:10:23 <garrett_> and the pages are somewhat simple on purpose for several reasons
15:10:38 <garrett_> it's mainly just some columns
15:10:43 <garrett_> I can do that with CSS
15:10:43 <dneary> garrett_, I don't know if there's a MediaWiki way to turn off the wiki menus for just some pages... like I said, IIRC from my MeeGo days, you need to have a separate page template in the theme for each page you want to do differently.
15:11:09 <dyasny> cctrieloff, I have been looking for a ready made engine, for wordpress, like we agreed with quaid, but it seems like I'll need to refocus on WM
15:11:22 <garrett_> dneary, there was a way around 8 years ago to do so in MW
15:11:31 <garrett_> so I would be surprised if there isn't today
15:11:52 <garrett_> absolute worse case scenario is hiding it via CSS if you're not signed in
15:12:06 <garrett_> end result is that it'd look as intended, regardless of the HTML on the page
15:12:13 <quaid> garrett_: the add-ons are for oVirt itself - vdsm-hooks, plugins, etc.
15:12:34 <garrett_> how is that being developed right now?
15:12:36 <quaid> garrett_: cf. https://extensions.gnome.org/
15:12:51 <garrett_> is there going to be a way to install it directly into an oVirt instance?
15:13:01 <quaid> it's not being developed yet, dyasny was looking in to doing it with WP becuase that fits the current site, and we would probably have to write a new plugin for it
15:13:01 <dyasny> garrett_, ^^ but more along the lines of marketplace.redhat.com or gallery.zimbra.com
15:13:07 <garrett_> (like GNOME extensions and WordPress plugins)
15:13:17 <dneary> garrett_, I'm happy to do a sample page, and see if we can figure out how long it'll take for the whole site from there
15:13:18 <dyasny> garrett_, no, the vdsm hooks are RPMs
15:13:37 <garrett_> it's probably okay to have a similar theme that's different for that
15:13:51 <garrett_> it's not content to read, really
15:14:08 <garrett_> (but I think that content to read should be all in the same site, with the same look and feel)
15:14:16 <dyasny> garrett_, there's some content, about a page long
15:14:22 <dneary> garrett_, re dyasny, I've previously suggested we might want user comments, ratings, download stats.
15:14:38 <dyasny> dneary, agreed, I'd love to see those in there
15:14:41 <dneary> garrett_, Potentially a front-end to a Yum channel
15:14:46 <RobertM> All stuff I have done in drupal
15:14:54 <dyasny> dneary, not potentially, we'll need our own repo in there
15:15:10 <dneary> dyasny, Will oVirt handle RPMs, regardless of the platform VDSM is running on?
15:15:22 <dneary> (as in, what happens when VDSM works on Ubuntu?)
15:15:26 <dyasny> dneary, because I want it usable for more than just fedora, and EPEL will not take vdsm-hooks
15:15:41 <dyasny> dneary, ubuntu can package their own, or we can add a PPM
15:15:44 <mburns> dneary: for ubuntu, when we get there, we'll have them packaged as .debs too
15:15:54 <dyasny> dneary, for now I want a set of RPMs that are not tagged with f17
15:16:27 <garrett_> so you wouldn't interact with the site really?
15:16:33 <garrett_> the VDSM plugin site?
15:16:46 <garrett_> you'd copy a string and paste it into the oVirt web UI to add it?
15:16:54 <dneary> garrett_, To find the plug-ins you're interested in, you would
15:17:01 <dneary> And to find out what others thought of it
15:17:05 <garrett_> or would the oVirt web UI have an iframe or some XML-RPC (or whatever) to communicate?
15:17:25 <garrett_> so you could just add extensions via the web UI of oVirt?
15:17:28 <garrett_> like a single click?
15:17:41 <dyasny> garrett_, the hooks need a site that would provide details on every hook, usage and examples, and so on
15:17:57 <dyasny> garrett_, and a link to download the RPM
15:18:05 <garrett_> right, but shouldn't that kind of exist on the oVirt web UI instead?
15:18:14 <garrett_> and then no RPMs or DEBs or anything
15:18:24 <RobertM> garrett_, Since hooks are installed in the nodes not the engine it is doubtful at least at 1st that will be an option.
15:18:28 <garrett_> but just a button you click and it does whatever it needs to, to directly install it in oVirt?
15:18:28 <dyasny> garrett_, no, hooks are external additions
15:18:48 <garrett_> dyasny, what do you mean external additions?
15:18:48 <dneary> I still wonder if "Documentation" is a good top-level menu item
15:18:52 <dyasny> garrett_, that's a pretty serious feature to code, even if it would be cool to have
15:19:09 <garrett_> dyasny, is it more serious than having it on the website?
15:19:14 <garrett_> I think it would be much more useful
15:19:18 <dyasny> garrett_, a vdsm hook is a set of scripts that go to the hosts, not the engine.
15:19:33 <garrett_> but the engine controls the hosts, right?
15:19:40 <dneary> It doesn't really tell you if it's user documentation/troubleshooting, developer documentation (in reality, we'll be linking to documentation from all over the place - "Getting started" will be documentation, for example)
15:19:44 <garrett_> it can instrument it... I'd think
15:20:05 <garrett_> dneary, yes, it's both, grouped into the type of documentation
15:20:06 <dyasny> garrett_, it's pretty heavy IMO - requires GUI integration, verifications, a channel to make the hosts get the hook and install it... not trivial
15:20:14 <garrett_> and developer docs go under develop
15:20:40 <garrett_> dyasny, but don't we need something like that regardless?
15:20:42 <dyasny> garrett_, so while yes, it would be useful, ovirt is missing much more needed features for this to be prioritized
15:20:51 <dneary> garrett_, This might be a nit - please feel free to say so if you think it is - but instead of "start using oVirt now", what do you think about "Get started with oVirt now"?
15:21:04 <garrett_> dneary, sure, that can be changed
15:21:11 <RobertM> garrett_, I think what dyasny is looking for is something like this http://drupalmodules.com/
15:21:16 <garrett_> dneary, I needed to write text for all of this; it might be a little rough in places
15:21:18 <dneary> garrett_, Feels like a nit now that I've said it out loud
15:21:21 <dyasny> garrett_, so for now, we need a site that provides a list of these plugins with explanations and download links, in the future, we can get rid of the links
15:21:35 <dyasny> RobertM, yup, that's another good example
15:21:47 <dneary> garrett_, And I (and perhaps sgordon and jbrooks) can help with copy
15:22:17 <garrett_> dyasny, how is it much different from someone manually downloading an RPM or DEB and then transferring things manually over, instead of having the system _know_ what it needs, and then download it itself?
15:22:30 <RobertM> I have done stuff like that in drupal.  Haven't personally do it in wordpress
15:22:37 <dneary> garrett_, Also, the documentation page should really say something other than "Coming soon". Can we expand on that, please?
15:22:58 * dneary ducks
15:23:03 <sgordon> i think that was explained in the text of the emails
15:23:04 <dyasny> garrett_, lets discuss the website and not ovirt features for now, when the meeting is over, we can take it into a separate channel or a phonecall
15:23:12 <sgordon> that it would be a list of links to documentation regardless of source
15:23:18 <sgordon> blog posts, wiki pages, formal stuff, etc
15:23:23 <garrett_> okay
15:23:26 <garrett_> that sounds good
15:23:47 <RobertM> garrett_, I guess it depends on if every plug-in is included in the repo.
15:24:02 <garrett_> sgordon, yeah, it is... but how many sources would we need?
15:24:20 <garrett_> RobertM, yeah, they should be though, in most every case... right?
15:24:37 <sgordon> mmm i dunno about that
15:24:56 <garrett_> sgordon, about what? (which conversation?)
15:25:06 <sgordon> i guess ultimately the answer is yes but i am not sure the vdsm maintainers are stepping up to include every submitted vdsm hook
15:25:10 <sgordon> in the official packaging
15:25:15 <sgordon> dyasny, ?
15:25:22 <garrett_> how hard is it to package the hooks?
15:25:30 <sgordon> that is actually what i think we are trying to move away from
15:25:38 <garrett_> shouldn't they all follow the same template, and be able to be packaged pretty easily?
15:25:44 <dyasny> sgordon, well, if you have a hook and want it to be known, you should commit to ovirt
15:25:44 <garrett_> (in one way or another?)
15:26:28 <sgordon> sure dyasny, but if that is happening why do we need a page for downloading them at all
15:26:45 <dneary> sgordon, I like pointing to 3rd party blog posts that talk about oVirt (contrib docs, oVirt in the news, that kind of thing), but I'd like to see us republish good docs on ovirt.org - in case the blog/article goes away
15:26:52 <RobertM> Hooks should be pretty easy to package up. Since they are just a mater of confirming a the hooks enabled VDSM is installed and coping a file to a folder
15:27:00 <dneary> sgordon, I have about 30% dead links on old blog posts these days :(
15:27:09 <sgordon> dneary, i am the messenger
15:27:15 <sgordon> it was in the emails about the design
15:27:32 <garrett_> how large are the hooks? how many will there be?
15:27:42 <dneary> sgordon, My "Coming soon" comment was intended to lighten the mood
15:28:05 <dneary> dyasny, Are they usually scripts, or binaries?
15:28:16 <sgordon> they are usually scripts
15:28:20 <sgordon> they dont technically have to be
15:28:20 <garrett_> you could just ship all of them in an off state, perhaps? or some in an add-on pack (which might get updated more frequently than oVirt itself), off by default
15:28:24 <dyasny> dneary, scripts, but anything executable works
15:28:26 <sgordon> but it's a lot easier to write them as scripts
15:28:28 <RobertM> Hooks themselves are under 1K even packaged up most will be under 1 k
15:28:31 <quaid> dneary: white wine usually lightens the mood, from red to pink
15:29:06 * RobertM strokes fire.
15:29:39 <dneary> badum-tish!
15:29:43 <RobertM> What about no Fedora packages?  aka Debian or suse
15:29:54 <RobertM> no=none
15:30:19 <dneary> garrett_, Is there anything in particular you'd like to get input on to allow you to move forward?
15:30:39 <dneary> I was considering suggesting we put an end to the meeting and officially turn this into "talking on IRC"
15:30:49 <garrett_> if people could respond to each section in the design email, that would be fantastic
15:30:53 <garrett_> like, even if they just like it
15:31:13 <garrett_> for instance, for all the headings in this one: http://people.redhat.com/glesage/oVirt/website/background-info/design.html
15:31:43 <garrett_> it sounds like people are on board with the packaging & download strategy of http://people.redhat.com/glesage/oVirt/website/background-info/design-download.html — but that it might take a little bit of time
15:33:04 <garrett_> and, if people are fine with some content system (hopefully just one) where people can edit it and the end result looks nice, that would be great too
15:33:10 <sgordon> well, there are some issues there with live media for ovirt
15:33:11 <garrett_> (even if that means MediaWiki)
15:33:18 <sgordon> it's a bit of a trade off in usability
15:33:26 <garrett_> sgordon, what are the issues?
15:33:32 <sgordon> mainly storage
15:33:33 <garrett_> and can those be solved?
15:33:37 <sgordon> to have a usable ovirt environment
15:33:42 <dneary> garrett_, Logo: I like it. No-one complained. Let's try to go with it. we should talk to legal to ensure there are no TM issues.
15:33:45 <garrett_> it can be installed, right?
15:33:51 <garrett_> dneary, okay, sounds good
15:33:55 <sgordon> on usb you can technically do it but the overlay works in a way that takes it away quickly
15:34:01 <sgordon> yes but then it isnt "live" media
15:34:04 <dneary> garrett_, Color: Universal good feedback - let's go with green.
15:34:15 <jbrooks> In my experiments, the live usb storage goes fast
15:34:16 <garrett_> I did have some wilder redesigns of the logo, but decided to go with the simpler tweak as you see
15:34:21 <dneary> Style: Idem. Great stuff.
15:34:41 <garrett_> sgordon, jbrooks: storage doesn't have to be only on the live image
15:34:43 <dneary> Site structure: Anything based on my work must be great ;-)
15:34:44 <sgordon> jbrooks, yeah exactly - i havent tried it but the way ovirt uses storage i expect eats it quickly
15:34:57 <sgordon> garrett_, yes but that is my point because that is a trade off in the usability of it
15:35:02 <jbrooks> Yes, but then you lose the all in one, so... why not install to disk
15:35:17 <garrett_> sgordon, I think that's okay
15:35:23 <sgordon> having a bootable live image isnt much good
15:35:29 <sgordon> if it's byo network filer
15:35:38 <dneary> I've given you my feedback & concerns about this - the one thing I wonder is whether the person who wants to report a bug/as devs a question will find his way on the current draft. Would you click on the "Community" link or the "Develop" link if you're neither a developer or a member of the community?
15:35:43 <garrett_> jbrooks, all-in-one means you can install both main parts of oVirt on one machine and have it working w/o other computers
15:35:45 <garrett_> just one computer
15:35:52 <jbrooks> That's right
15:36:13 <garrett_> the live image is for booting and installing, mainly
15:36:29 <garrett_> perhaps not running live... but if so, then there should be some sort of non-USB/CD storage in that case, perhaps?
15:36:42 <ovirtbot> 14[[07Bangalore Abstracts14]]4 !N10 02http://wiki.ovirt.org/w/index.php?oldid=4366&rcid=4470 5* 03Lh 5* (+1314) 10Created page with "The purpose of this page is to document talk proposals submitted for the [http://ovirtbangalore2012.eventbrite.com/ oVirt Bangalore workshop] to be hosted at Red Hat's campus.  =..."
15:36:42 <dneary> garrett_, Also the comments I made earlier re documentation - I have no problem linking to outside content, but we should ask for permission to republish good docs on the site, so as to ensure we don't lose them if the site goes down/changes URL naming scheme
15:36:47 <garrett_> you probably want a NAS or some other sort of storage regardless
15:36:51 <jbrooks> Yes, a install disc would be helpful
15:37:21 <garrett_> dneary, naturally... do you mean blog posts in this case?
15:37:28 <dneary> Tagline: So easily changable that I would not lose time worrying about it right now. "Open your virtual datacenter" is fine.
15:37:32 <sgordon> garrett_, my point is more that for most people live media means being able to use it without installing anything
15:37:32 <dneary> garrett_, Yes
15:37:38 <garrett_> dneary, the content should be under an open license and pulled in when possible
15:37:40 <sgordon> for ovirt i dont think that is really feasible
15:37:47 <sgordon> an install disc however should be
15:37:53 <sgordon> probably defaulting to all in one
15:37:57 <dneary> garrett_, But as I said to sgordon, I am now up to about 30% dead links in old (pre-2006) blog posts now
15:38:04 <garrett_> sgordon, yes, it's probably a little different for oVirt
15:38:09 <jbrooks> What's the main tool for making install discs in fedora -- is it pungi?
15:38:19 <sgordon> i cant remember, there is a lot of material though
15:38:25 <sgordon> on creating spins and remixes
15:38:30 <garrett_> sgordon, but it would be useful for an evaluation mode
15:38:40 <jbrooks> Too much material -- I've gotten lost several times
15:39:12 <garrett_> we could even just demand that someone installs it to a machine somehow for evaluation — that's probably not a surprising requirement, especially considering our target audiences
15:39:20 <jbrooks> yep
15:39:26 <garrett_> but there should be a way to do that from a CD or USB stick
15:39:42 <sgordon> garrett_, that is what i would lean towards
15:39:42 <garrett_> and it should be able to be installed and working on one machine only (or more, optionally)
15:39:53 <sgordon> i think having a live media that isnt quite live because it requires external storage
15:39:56 <jbrooks> Yes, we can do that -- the live is the tricky part
15:39:57 <sgordon> is more confusing than helpful
15:40:01 <garrett_> the main goal is to have one file to download and then install from
15:40:05 <garrett_> and that's it
15:40:10 <jbrooks> But it all works on one machine to testing pretty well
15:40:18 <sgordon> yeah
15:40:28 <garrett_> sgordon, yep, probably
15:40:34 <sgordon> i also have scripting to do all in one in a virtual machine that i am working on getting to git hub
15:40:37 <garrett_> sgordon, I was thinking that external storage could be NAS though
15:40:42 <garrett_> over the network somehow
15:40:47 <dneary> Supporting lead-in text: I suggest we can almost Lorem Ipsum this for the moment - I like your lead-in, but maybe we can do better.
15:40:56 <garrett_> so live would cork with network storage
15:40:58 <jbrooks> When I see live, I think, not going to write to any drive
15:40:59 <garrett_> could work
15:41:21 <garrett_> jbrooks, yeah, I can see that viewpoint, and that's probably expected
15:41:26 <garrett_> live++? (jk)
15:41:35 <sgordon> yeah, that is what i am thinking too jbrooks
15:41:45 <dneary> garrett_, "Call to action" - definitely needed, the suggestion I made earlier is a minor tweak
15:42:10 <quaid> fwiw, Robert raised a good point - we might find Drupal is the key here, as it has all we are looking for in one, lots of modules in the ecosystem, etc.
15:42:27 <garrett_> Drupal might be a solution instead of MediaWiki
15:42:34 <garrett_> but I don't know about that so much
15:42:37 <dneary> garrett_, Front page sections: I have previously given my feedback there; I think it's mostly excellent, and the various concerns I had, I think you're aware of.
15:42:42 <quaid> ... although I hates the Drupal wiki tool, at least as I've experienced it
15:42:42 <ovirtbot> quaid: Error: ".." is not a valid command.
15:42:53 <dneary> quaid, Drupal wiki sucks
15:43:08 <dyasny> quaid, dneary: why not just use MW and Drupal?
15:43:10 <dneary> If we want a wiki (and I think we do), I would be tempted to veto just for that reason
15:43:21 <dyasny> dneary, what about joomla?
15:43:22 <garrett_> dyasny, see above about the two different systems for content
15:43:40 <garrett_> if it's content, then it should just be in the one content system of choice
15:43:47 <quaid> dneary: I was hoping Drupal 7 + modules to fix it's wiki would be better than I've experienced
15:43:51 <garrett_> ( which is whatever we choose)
15:43:53 <dneary> dyasny, We're back to the one tool or two? discussion - I am not bothered about multiple tools, but Garrett would like to avoid, where possible, redoing design work on N tools
15:43:58 <dneary> where N>1
15:43:58 <garrett_> one tool
15:44:14 <garrett_> if you have a subsite for non-document-content, it's different
15:44:32 <garrett_> (like a marketplace of add-ons, for example)
15:44:43 <dyasny> garrett_, then we need one GOOD CMS for the entire thing. If Drupal is a potential nack for it's bad wiki, we can look at others, like joomla
15:44:48 <garrett_> (the hooks aren't document content)
15:44:54 <sgordon> i think one tool would be preferable
15:45:03 <sgordon> i am just not sure that is still the case if it's MW...
15:45:03 <dneary> garrett_, If there is anything I can do to give you feedback on revised designs, please do let me know - and when you need copy-editing help, shout.
15:45:03 <quaid> btw, dneary , I think mburns gave you chair to close the meeting, so you can call for that if you wish
15:45:12 <dyasny> garrett_, they kinda are, unless I misinterpret the "document" part
15:45:16 <dneary> quaid, The meeting close, you mean?
15:45:17 <garrett_> we shouldn't cripple the site just because of some other part
15:45:26 <garrett_> dneary, thanks!
15:45:33 <quaid> oh, I think the arguments against using MW are resolveable - it's all about aesthetics we can fix
15:45:36 <sgordon> that is actually my reason for being skeptical of MW garrett_ :P
15:45:42 <dneary> garrett_, Did I cover eack section? :-)
15:45:42 <garrett_> dneary, we definitely need some copy editing, but we're not quite there yet
15:46:00 <dneary> Calling an end to the meeting.
15:46:02 <dneary> Going...
15:46:03 <garrett_> sgordon, MW is a solution for documents
15:46:06 <dneary> Going...
15:46:10 <garrett_> dneary, yeah, it sounds good
15:46:10 <dneary> Gone.
15:46:14 <dneary> #endmeeting