14:01:34 <oschreib> #startmeeting oVirt Weekly Sync
14:01:34 <ovirtbot> Meeting started Wed Jun  6 14:01:34 2012 UTC.  The chair is oschreib. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:34 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:45 <oschreib> #topic agenda and roll call
14:01:51 * aglitke is here
14:01:56 * mgoldboi is here
14:02:01 * oschreib here
14:02:29 * fabiand is trying to speak for node
14:02:31 <oschreib> Agenda is
14:02:31 * itamar his here
14:02:36 <oschreib> 1. Release status
14:02:44 <oschreib> 2. sub project status
14:02:46 * danken is lurking
14:02:54 <oschreib> 3. workshops/conferences
14:03:02 <oschreib> 4. Other topics that people have
14:03:06 * dustins here
14:03:07 <oschreib> anything else?
14:03:14 * doron here
14:03:32 <rickyh> \me here
14:03:36 <oschreib> waiting 1 min for roll-call
14:03:44 * rickyh here
14:03:44 * sgordon_ is here
14:04:21 * mestery lurking ...
14:04:32 <oschreib> #topic Release status
14:04:44 <oschreib> #info devel freeze June 7 (tomorrow)
14:04:50 <oschreib> #info Beta shortly after
14:04:56 <oschreib> #info GA June 27
14:05:07 <oschreib> #info test day June 14
14:05:21 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=822145
14:05:30 <oschreib> Fedora 17 patch finally merged
14:06:27 <oschreib> engine <-> vdsm version issue solved
14:06:35 <oschreib> only one issue blocking node - https://bugzilla.redhat.com/show_bug.cgi?id=824420
14:06:51 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=824420
14:07:07 <oschreib> one node blocker
14:07:32 <oschreib> agreed with mburns that we can enter feature freeze
14:07:48 <oschreib> so, any objections on entering feature freeze tomorrow?
14:08:03 <oschreib> feel free to +1 it
14:08:10 <itamar> +1
14:08:12 <mgoldboi> mgoldboi: +1
14:08:20 <dustins> +1
14:08:23 <doron> +1
14:09:04 <oschreib> #agreed ovirt 3.1 feature freeze will be 07.06.2012 (tomorrow)
14:09:09 <eedri> +1
14:09:17 <oschreib> #info node should be ready few days after
14:09:35 <oschreib> another small issue - I going to one week vacation
14:10:13 <oschreib> mburns volunteered to replace me as release manager for next week
14:10:31 <oschreib> (he's in japan currently, I'm speaking in his name)
14:10:40 <oschreib> any objections? or +1's?
14:11:06 <mgoldboi> mgoldboi: +1
14:11:34 <itamar> +1
14:11:39 <dustins> +1
14:11:42 <eedri> +1
14:11:47 <aglitke> #info vdsm is in feature freeze
14:12:35 <doron> +1
14:12:42 <oschreib> #chair aaglitke
14:12:42 <ovirtbot> Current chairs: aaglitke oschreib
14:13:09 <oschreib> #chair aglitke
14:13:09 <ovirtbot> Current chairs: aaglitke aglitke oschreib
14:13:16 <aglitke> :)
14:13:17 <danken> I think it would be nice if vdsm has a version bump for the freeze (4.9.7)
14:13:31 <oschreib> #agreed mburns will be release manager next week
14:14:05 <oschreib> #action mburns to replace oschreib as release manager next week
14:14:06 <itamar> can it go with 4.10 to match what it reports to engine? or will it go to 5.0 for next version instead?
14:14:06 <aglitke> danken, I assume the bug fixes then would not bump the version?
14:14:18 <oschreib> ok
14:14:25 <doron> danken: +1 on bump if engine can handle that.
14:14:28 <oschreib> if we're already talking about vdsm
14:14:29 <oschreib> #topic sub project status -- vdsm
14:14:46 <danken> doron: yeah, we'd keep reporting 4.9...
14:14:53 <doron> :)
14:14:58 <aglitke> vdsm uses x.y.z versions
14:15:13 <danken> aglitke: indeed, bug fixes are on top of that version - could be rpm releases
14:15:18 <aglitke> so best we could do is 4.10.0 and lie to engine 4.10
14:15:23 <oschreib> are we sure we want to change it? won't it break anything?
14:15:56 <aglitke> how does engine handle the version bump?  (assuming 4.10) ?
14:15:59 <danken> aglitke: for some reason abaron (and you?) were against 4.10 yeasterday, not?
14:16:29 <aglitke> danken, for a release I would think 4.10.0 is okay
14:16:38 <danken> aglitke: it could work out of the box, but Engine should probably say that it supports 4.10.
14:16:42 <aglitke> since it involves a feature freeze
14:16:49 <aglitke> yep
14:17:18 <aglitke> bug fixes could bump it to 4.10.x++
14:17:29 <aglitke> but it would still appear as 4.10 to engine
14:17:54 <oschreib> can you decide about the version until tomorrow? (+patch and test it?)
14:18:02 <ovirtbot> 14[[07Release Notes Draft14]]4 !N10 02http://www.ovirt.org/w/index.php?oldid=3479&rcid=3568 5* 03Sgordon 5* (+648) 10Populated draft release notes page for 3.1
14:18:05 <itamar> danken, engine only needs to say it supports 4.10 if vdsm doesn't say it support 3.1, which it already does.
14:18:14 <danken> aglitke: I did not understand why you and ayal said no for thaton yesterday vdsm call,...
14:18:34 <ovirtbot> 14[[07Release Notes Draft14]]4 !10 02http://www.ovirt.org/w/index.php?diff=3480&oldid=3479&rcid=3569 5* 03Sgordon 5* (+18) 10/* Engine */ 
14:18:44 <aglitke> danken, I didn't want to bump it just to work around an engine version parsing problem.
14:18:59 <ovirtbot> 14[[07Release Notes Draft14]]4 !10 02http://www.ovirt.org/w/index.php?diff=3481&oldid=3480&rcid=3570 5* 03Sgordon 5* (+22) 10/* VDSM */ 
14:19:07 <aglitke> It's logical to bump the 'y' part of the version for an ovirt release.
14:19:08 <danken> aglitke: ah
14:19:26 <aglitke> on our end, the version needs to be 4.10.0
14:19:29 <aglitke> agreed?
14:19:49 <danken> I'll have to understand abaron's yesterday's rejection of this
14:20:00 <aglitke> ok...
14:20:03 <oschreib> danken: can you close it until tomorrow?
14:20:04 <danken> but my opinion is positive for this
14:20:11 <danken> oschreib: yes
14:20:20 <oschreib> #agreed vdsm version should be bumped
14:20:21 <danken> otherwise - it's 4.9 still.
14:20:35 <oschreib> #action danken to handle vdsm version until tomorrow
14:20:43 <oschreib> anything else from vdsm?
14:20:50 <aglitke> not from me...
14:21:15 <oschreib> #topic sub project status -- engine
14:21:22 <oschreib> how do things look on the engine side for devel freeze?
14:22:14 <oschreib> doron: ? itamar?
14:22:29 <doron> oschreib: afaik pretty much there.
14:23:00 <oschreib> #info things in good shape on the engine side
14:23:01 <itamar> should go to feature freeze. if anything worth while we could discuss an exception to it when raised (can't think of any now)
14:23:31 <oschreib> #topic sub project status -- node
14:23:55 <oschreib> fabiand: ?
14:24:10 <fabiand> well, we are on a good track
14:24:21 <fabiand> we had some trouble with selinux changes and blocker that kept us a while from progressing
14:24:40 <oschreib> are you talking about https://bugzilla.redhat.com/show_bug.cgi?id=824420?
14:24:42 <fabiand> We've got hope that we can fix this in the next days
14:25:18 <fabiand> yes, our major effort is currently to get node working on an F17 base
14:25:39 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=824420
14:26:01 <oschreib> #info node should support F17 in the next couple of days
14:26:17 <oschreib> fabiand: please update that bug with some relevant info
14:26:23 <fabiand> oschreib, sure
14:26:50 <oschreib> #action fabiand to update BZ#824420
14:27:17 <oschreib> #topic Workshops and Conferences
14:27:57 <oschreib> itamar: quaid_ : any info about that topic? lh is not here
14:28:58 <itamar> barak and mburns are presenting in linux con japan this week :)
14:29:08 <itamar> no other updates i'm aware of.
14:29:40 <oschreib> #info bazulay and mburns are presenting ovirt in linux con Japan this week
14:29:40 <itamar> upcoming ovirt day in linuxcon NA, then 2.5 co-hosted with kvm forum in linuxcon europe
14:30:55 <oschreib> cool
14:31:43 <oschreib> #info there will be an ovirt day in n linuxcon NA, then 2.5 co-hosted with kvm forum in linuxcon europe
14:31:48 <oschreib> #topic Other Topics
14:31:55 <oschreib> one thing from me:
14:32:25 <aglitke> I have two things after oschreib
14:32:28 <oschreib> I've created http://www.ovirt.org/releases/beta/fedora/17/
14:32:45 <oschreib> with pre feature freeze F17 build
14:32:51 <oschreib> feel free to test them
14:33:24 <oschreib> #link http://www.ovirt.org/releases/beta/fedora/17/
14:33:40 <oschreib> #info pre feature freeze F17 builds
14:33:52 <oschreib> who's taking the lead on test day next week?
14:34:33 <aglitke> I was going to ask the same.  I would like to encourage my team at IBM to participate.
14:35:40 <oschreib> ykaul1: yeylon_: any volunteers ?
14:36:15 <oschreib> aglitke: that would be great, we need someone to arrange it though
14:36:38 <aglitke> I'm afraid I don't have the bandwidth to lead it.
14:36:47 <oschreib> I'll have to take it to the mailing list.
14:36:51 <aglitke> ok.
14:37:03 <oschreib> #action oschreib to look for test day lead
14:37:08 <oschreib> aglitke: anything elese?
14:37:23 <aglitke> yes
14:37:50 <aglitke> danken wanted me to mention that the vdsm verb setupNetwork is broken.  It is missing some basic features such as adding a nic to an existing bond device.
14:38:14 <aglitke> setupNetwork is part of the release criteria I guess.
14:38:29 <oschreib> do we have an 3.1 blocker bug on it?
14:38:34 <aglitke> I think this just needs to be noted in the meeting log for posterity.
14:38:40 <aglitke> I can check,
14:38:55 <oschreib> aglitke: can you make https://bugzilla.redhat.com/show_bug.cgi?id=822145 depends on it?
14:39:01 <yeylon_> oschreib, mgoldboi did a great job last time, i say why kill a winning coiw... ;)
14:39:11 <aglitke> oschreib, sure.
14:39:15 <oschreib> #info vdsms's setupNetwork is broken
14:39:48 <oschreib> #action aglitke to link setupNetwork bug on https://bugzilla.redhat.com/show_bug.cgi?id=822145
14:40:06 <itamar> aglitke - actually, we could debate if setupNetworks is on the release criteria, or allowing old api for 3.1 is a good enough resolution
14:40:57 <itamar> (assuming it isn't broken as well)
14:40:58 <aglitke> itamar, ok.  I defer to the experts :)
14:41:18 <oschreib> aglitke: please make sure engine-devel is updated with that issue
14:41:26 <oschreib> we will have to discuess it next meeting
14:41:27 <itamar> but agree nework working is blocking
14:41:38 <oschreib> anything else?
14:41:43 <aglitke> not for me
14:42:12 <danken> +1 for dropping setupNet from release criteria
14:42:20 <danken> I think it is immature in all levels
14:42:45 <oschreib> danken: please send such an offer to the relevant list
14:42:52 <oschreib> we will revisit it next meeting
14:43:49 <oschreib> ok
14:44:14 <oschreib> ending meeting in 5
14:44:19 <oschreib> 4
14:44:20 <ykaul1> danken: and what is the alternative to setupNet?
14:44:34 * oschreib reset counter
14:45:28 <danken> old-fashioned api of 3.0 release
14:45:30 <danken> ykaul: ^^
14:45:59 <aglitke> Perhaps we can discuss the whole issue on the list when danken sends out the email.
14:45:59 <ykaul> danken: but that requires some work, that is not going to be done in time for the 3.1 release, or we'll have to delay it, no?
14:46:45 <danken> ykaul: what "requires some work"?
14:46:49 <itamar> ykaul, why? we still support it in both engine and vdsm for 3.0 clusters. we just need to say 3.1 clusters use old code path in engine
14:47:00 * danken ahhh battary low
14:47:25 <ykaul> itamar: in theory, yes. In practice, I don't know. And I'm pretty sure the UI is still broken. Also, will VDSM advertising as 3.1 would work with old API?
14:47:39 <itamar> yes, it will work with old api
14:47:40 <ykaul> or 4.9.7 VDSM or whatever version we end up with.
14:47:57 <danken> yeah, we keep backward compat
14:48:06 <danken> old api is NOT deprecated
14:48:23 <danken> we could spend some time stabilzing setupNet
14:48:39 <danken> I'm just saying that I feel that 1 month may be a bit too short a time
14:49:51 <ykaul> oschreib: forgot to respond that I will not be leading the test day. Nor will yeylon. Will have to find someone from the community.
14:50:10 <oschreib> ykaul: got that.
14:50:22 <oschreib> danken: sounds like a (very) long discuession
14:50:44 <oschreib> danken: can you lead the discussion on @ovirt.org ?
14:51:09 <danken> oschreib: regarding setupNetwork?
14:51:18 <oschreib> yes
14:51:43 <oschreib> regarding it's maturity for ovirt 3.1
14:52:04 <danken> ok. until I do, setupNet is in the release criteria, and we'll strive to stabilize it
14:52:14 <oschreib> indeed
14:52:34 <ykaul> danken: I thought the release criteria was about network working, setupNetwork is a small implementation detail.
14:52:52 <ykaul> danken: I suspect the UI is a bit broken as well. not sure the latest status.
14:54:29 <oschreib> anything else?
14:54:37 <oschreib> or can we end the meeting?
14:55:21 <oschreib> end meeting in 5
14:55:23 <oschreib> 4
14:55:27 <oschreib> 3
14:55:30 <oschreib> 2
14:55:34 <oschreib> 1
14:55:40 <oschreib> #endmeeting