15:01:25 <quaid> #startmeeting
15:01:25 <ovirtbot> Meeting started Wed Mar 28 15:01:25 2012 UTC.  The chair is quaid. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:25 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:38 <mburns> itxx: it's by design
15:01:42 <quaid> #meetingname oVirt project weekly sync
15:01:42 <ovirtbot> The meeting name has been set to 'ovirt_project_weekly_sync'
15:01:50 <quaid> #topic Roll call & greetings
15:01:51 <mburns> if you want that level of control, you can always use fedora instead
15:01:53 <quaid> Hi everyone!
15:02:00 <mburns> but ovirt-node is meant to be small footprint and firmware like
15:02:25 * sgordon_ is here
15:02:38 <mburns> you don't (generally) go into your router and mess around in the filesystem
15:02:40 * oschreib here
15:02:45 * mgoldboi here
15:02:50 <mburns> and that's the role ovirt-node is trying to fill
15:02:52 * mburns here
15:03:04 <cctrieloff> here, but distracted for first part of meeting
15:03:24 <itxx> oh,i think i can understand now,thanks.
15:03:31 * fabiand is here
15:03:51 <mburns> itxx: not a problem
15:04:04 * mburns makes note to add that question to a FAQ about ovirt-node
15:05:11 <quaid> #topic Agenda review
15:05:20 <quaid> #link http://ovirt.org/wiki/Meetings#Weekly_project_sync_meeting
15:05:34 <quaid> so I started gathering and posting an agenda in advance at the above URL
15:05:53 <quaid> will try to do so in the future, including have regular items that appear there
15:06:01 <quaid> This is the agenda for the 2012-03-28 meeting:
15:06:02 <quaid> Release status check-in
15:06:02 <quaid> Fedora 17 support:
15:06:02 <quaid> What is F17 feature schedule?
15:06:02 <quaid> When do we start build packages for and testing with F17?
15:06:04 <quaid> Do we want to start automatically moving builds from jenkins to the nighly releases on ovirt.org?
15:06:07 <quaid> Infrastructure status:
15:06:10 <quaid> Current situation ...
15:06:12 <quaid> Some plans to improve ...
15:06:15 <quaid> Anything else?
15:06:19 <quaid> so, before we go forward, does anyoone want to add something right now?
15:06:38 <quaid> ah, I know
15:06:39 <sgordon_> What is F17 feature schedule? err what?
15:06:40 <mburns> quaid: oschreib mentioned last week if it made sense to move this to a bi-weekly meeting
15:06:51 <sgordon_> shouldnt that be F18?
15:06:56 <quaid> * Workshop report (from Carl)
15:07:09 <quaid> sgordon_: huh, good question
15:07:16 <mburns> sgordon_: currently all builds we have in jenkins are f16 targeted
15:07:16 <sgordon_> F17 is pretty much out the door lol
15:07:24 <quaid> mburns: I'd be OK with that, we should discuss on arch@
15:07:40 <quaid> oschreib: do you want to bring that up on the list?
15:07:42 <sgordon_> mburns, i assumed we meant in terms of having ovirt packages in fedora itself
15:07:55 <oschreib> quaid: bring what? the F17 issue?
15:07:55 <sgordon_> https://fedoraproject.org/wiki/Features/oVirt
15:08:20 <quaid> oschreib: the idea of moving to a every-other-week meeting?
15:08:32 <oschreib> quaid: will do.
15:08:39 <quaid> sgordon_: that page says F17
15:08:44 <sgordon_> yes quaid
15:08:48 <sgordon_> but it didnt make it
15:08:50 <sgordon_> so again
15:08:54 <quaid> mburns: weren't the above questions yours?
15:08:57 <sgordon_> i ask dont we mean F18
15:09:01 <mburns> quaid: yes
15:09:05 <oschreib> sgordon_: afaik, you can always push packages into F17....
15:09:07 <quaid> sgordon_: you are probably right, but let's ask mburns what he meant
15:09:11 <mburns> let's discuss when we get to that part of the meeting
15:09:18 <mburns> or are we there yet?
15:09:21 <quaid> oschreib: true, we don't have to wait for a release to finish packaging and push
15:09:27 <quaid> sorry, yes, let's move on
15:09:32 <oschreib> ok
15:09:43 <quaid> #topic Release status check-in
15:09:59 <quaid> oschreib: no worries if nothing new, just wanted to have this as a regular agenda item so we check on release each time we meet :)
15:10:20 <oschreib> well, nothing new.
15:10:26 <oschreib> tons of patches into the engine
15:10:39 <oschreib> couple of cool features into the installer too
15:10:45 <oschreib> next version is going to be a blast.
15:11:05 <mburns> node had an intermediate release this last week
15:11:24 <mburns> and we'll have another around the time of feature freeze
15:11:31 <oschreib> mburns: why's that?
15:11:46 <mburns> oschreib: why did we have an intermediate release?
15:11:55 <oschreib> mburns: indeed
15:12:52 <mburns> oschreib: some cleanup, pick up some updated fedora packages
15:13:08 <oschreib> mburns: just wanted to know :)
15:13:41 <mburns> oschreib: we'll probably release our next version around end of april
15:14:01 <mburns> but do respin of the iso image itself as needed during the month of may for end of may release
15:14:09 <mburns> we want node to be as stable as possible for testing
15:16:11 <oschreib> quaid: nothing more in that field
15:16:15 <quaid> so it should be fine for sub-projects to do their own releases
15:16:21 <quaid> as long as the sync works for the Big Release, right?
15:16:48 <oschreib> IMO - ya. if that will make them more stable - +100 from me
15:16:55 <mburns> quaid: afa node is concerned, we almost have to do some sort of intermediate release
15:17:01 <mburns> to pick up fedora updates
15:17:16 <oschreib> releasing the engine is more difficult, so doing it frequent is hard.
15:17:32 <mburns> yes, node is much easier
15:17:33 <mburns> 2 packages
15:17:52 <mburns> one of which is a standalone ISO
15:18:00 <quaid> cool
15:18:17 <quaid> mburns: makes sense re: Node syncing to Fedora updates
15:18:26 <quaid> ok, sounds like we're ready to move on ...
15:18:50 <quaid> #topic Fedora 17 support, or do we mean Fedora 18?
15:19:10 <mburns> ok, so my argument was not about packages being directly in fedora repos
15:19:22 <mburns> but having packages available on ovirt.org for fedora 17
15:19:34 <mburns> http://ovirt.org/releases/nightly/fedora/17
15:19:40 <mburns> contains nothing at the moment
15:19:47 <sgordon_> similar to that, i tried to use mock to build some based on the SRPMs for engine
15:19:53 <sgordon_> and it appears to be missing BuildRequires
15:20:01 <sgordon_> particularly for maven
15:20:07 <oschreib> mburns: is there easy way to build f17 rpms, without having f17 installed? (mock probably?)
15:20:22 <mburns> the fedora/18 repo is also empty
15:20:25 <oschreib> sgordon_: any patches for that?
15:20:25 <sgordon_> so do the SRPMS we are putting on the site actually work in a clean environment? because to me it appears not?
15:20:35 <mburns> oschreib: probably mock
15:20:36 <aglitke> rgolan, Any ideas on how to extract comments via a gerrit query?
15:20:48 <sgordon_> oschreib, no, i want to know why...not convinced that is the only one missing yet either
15:21:19 <oschreib> sgordon_: lets take it off-list, I would like to help you with that.
15:21:21 <mburns> oschreib: node has conditions built into it to change based on the value of rpm --eval %fedora
15:22:22 <oschreib> mburns: which part of the node? the spec?
15:22:52 <mburns> oschreib: acutally, now that i think about it, the ovirt-node rpm probably needs to be built in mock
15:23:24 <oschreib> mburns: well, all rpms should be. #inaperfectworld
15:23:35 <mburns> but the iso makefile will read .rpmmacros for the value of %fedora and setup the repos it pulls packages from based on the value
15:23:59 <mburns> oschreib: ovirt-node doesn't have library dependencies or anything like that, so it's not as big a deal
15:24:51 <oschreib> mburns: we're not that smart. we have some code (bootstrap/setup) that depends on Fedora stuff. so build might be fine, but the installation won't pass
15:24:54 <mburns> oschreib: but i'll look at migrating the build to mock for f17/f18
15:25:25 <mburns> oschreib: shouldn't be too hard in mock (though i don't know much about it)
15:25:26 <oschreib> sgordon_: mburns: agreed we should make the Makefile and specfile better
15:25:33 <oschreib> mburns: same here.
15:25:46 <oschreib> sgordon_: will you help me with the spec/make changes?
15:25:52 <sgordon_> well, to get into fedora proper they will all need to work in mock eventually
15:26:12 <sgordon_> i will do my best yeah
15:26:18 <mburns> ovirt-node is in f17 already
15:26:25 <mburns> so it should be fine
15:26:25 <oschreib> sgordon_: actually, there's a separate spec, wore by Juan
15:26:32 <sgordon_> heh
15:26:48 <oschreib> sgordon_: which is in fedora review now.
15:27:01 <sgordon_> shouldn't we be trying to use the same one?
15:27:09 <oschreib> sgordon_: well, ya
15:27:24 <oschreib> sgordon_: but we cant use the current one in fedora
15:27:41 <sgordon_> well yeah, particularly the agent one
15:27:42 <oschreib> sgordon_: as it has some nasty requirements
15:27:45 <sgordon_> was never going to pass review
15:27:49 <quaid> #agreed make the Makefile and specfile better
15:28:10 <mburns> fedora spec can be much simpler
15:28:15 <oschreib> #action oschreib and sgordon to review spec and Makefile
15:28:16 <quaid> #info Need to get SRPMs building in mock so we can get in to Fedora
15:28:36 <mburns> doesn't need if blocks for rhel vs fedora vs centos, etc
15:28:37 <sgordon_> anyway, as far as F17/18 inclusion, my point was we proposed inclusion of this stuff as a feature for F17, yes technically we can push the packages that didnt make it into the release anyway
15:28:44 <oschreib> quaid: can I add action without beeing a chair?
15:28:51 <sgordon_> but that as i interpret it is an admission it shouldnt have been raised as a feature
15:28:53 <quaid> oschreib: yes
15:29:00 <oschreib> quaid: ok
15:29:13 <mburns> sgordon_: we at least will need to get vdsm built for f17
15:29:28 <oschreib> mburns: we already have one AFAIK
15:29:31 <sgordon_> whoever owns the feature page for fedora probably needs to update it to reflect whatever the current reality is
15:29:31 <mburns> otherwise an F17 based ovirt-node is useless
15:29:44 <mburns> oschreib: in fedora repos?
15:29:54 <mburns> latest release that we have on ovirt.org?
15:29:55 <sgordon_> http://koji.fedoraproject.org/koji/packageinfo?packageID=12944
15:30:00 <sgordon_> mburns, ^
15:30:06 <sgordon_> that is the link from the feature page for vdsm
15:30:08 <quaid> oschreib: chairs can start, stop, agree, and set topic - all other commands are open to anyone
15:30:21 <mburns> ok, thats good
15:30:28 <mburns> i had looked on ovirt.org and didn't see any
15:30:31 <quaid> #action Fedora feature page owner needs to update the feature page to current reality
15:30:34 <quaid> sgordon_: +1
15:30:53 <oschreib> quaid: the owner is Oved
15:31:02 <mburns> then i can get f17 builds rolling
15:31:37 <oschreib> https://bugzilla.redhat.com/show_bug.cgi?id=807017
15:31:44 <oschreib> this is the ovirt-engine for fedora ^^
15:33:21 <oschreib> it only contains the backend and rest
15:33:54 <oschreib> with massive patches on the 3.0.0 tar.gz
15:35:05 <mburns> ok, sounds like we have a path forward for all the major components w.r.t. f17/f18
15:35:13 <mburns> so we can prob move on
15:35:17 <quaid> ok
15:35:26 <quaid> can someone poke Oved about the feature page update?
15:35:33 <oschreib> quaid: I'll
15:35:42 * quaid doesn't like to mess with other people's feature pages :)
15:35:44 <quaid> ok
15:35:57 <quaid> moving on ...
15:36:06 <quaid> #topic Infrastructure status
15:36:22 <quaid> so I put this on partially to cover any open questions about last weeks disk-space-oops
15:36:49 <quaid> but also to just bring up the topic of needing a bit more infra help
15:37:26 <quaid> such as, feel free to remind people from the wider community that helping with infra is a great way to contribute
15:38:33 <mburns> along the same lines...  running meetings like this one is another good way to help
15:39:40 <mburns> quaid: if interested, what should people do, send mail to infra@ ?
15:42:17 <mburns> looks like we lost quaid
15:42:39 <oschreib> oh, nooo
15:42:50 <mburns> #info people interested in contributing to ovirt by helping with infra, send email to infra@ovirt.org
15:43:11 <mburns> #info people interested in helping run meetings, send email to infra@ovirt.org
15:43:42 <mburns> #topic automatically update nightly releases from jenkins
15:43:48 <mburns> bah, i'm not a chair
15:43:54 <mburns> #chair
15:44:45 <quaid> sorry f2f interruption
15:44:54 <quaid> #chair mburns
15:44:54 <ovirtbot> Current chairs: mburns quaid
15:45:12 <mburns> quaid: if you're back, i don't need to chair
15:45:13 <quaid> mburns: yeah, email to infra@ to help
15:45:14 <quaid> heh
15:45:17 <quaid> ok, but we can move on
15:45:28 <mburns> #topic automatically update nightly releases from jenkins
15:45:29 <quaid> I just wanted to bring that up, but I think i need to do a publicity campaign of sorts
15:45:37 <mburns> quaid: ack
15:45:53 <quaid> so what does it take to do auto updates?
15:46:02 <oschreib> auto updates?
15:46:03 <mburns> so we currently build things (whether nightly or on commit, or whenever...) in jenkins
15:46:22 <mburns> can we setup some sort of sync process to move these things to nightly releases?
15:46:34 <oschreib> sounds easy to me
15:46:37 <mburns> oschreib: ideally it would be auto-updates
15:46:44 <oschreib> ammm
15:46:53 <oschreib> I'm not an jenkins expert
15:47:03 <mburns> oschreib: could be driven from either jenkins as a job or as a script from ovirt.org
15:47:08 <oschreib> but the easiest thing would copy Jenkins build in some sort of cron
15:47:20 <oschreib> eedri: ping
15:47:30 <quaid> so, a pull script from ovirt.org or push from jenkins ...
15:47:39 <mburns> oschreib: easiest might be to have a cron job on ovirt.org that syncs from a known location on ovirt.org
15:48:19 <mburns> so a jenkins rpm build finishes and it pushes it's rpms to ovirt.org under /opt/new_nightlies
15:49:04 <mburns> and there is a sync script on ovirt.org that copies them from new_nightlies to the appropriate places and runs things like createrepo and calculates md5sums, etc...
15:49:56 <oschreib> how will jenkins push rpms into ovirt.org?
15:50:18 <mburns> oschreib: probably would need to setup some scp or rsync type push
15:50:32 <mburns> as an unprivileged user
15:51:18 <oschreib> mburns: the only issue is build version/release, it should be something like MAJOR.MINOR.YEAR_MONTH_DAY
15:51:35 <eedri> pong
15:52:06 <mburns> oschreib: something like that yes
15:52:15 <oschreib> eedri: any way to push nightly rpms into ovirt.org?
15:52:43 <mburns> oschreib: if you look at http://jenkins.ovirt.org/job/ovirt-node-stable/
15:52:48 <eedri> oschreib, as long as jenkins will have permissions to put the files there
15:52:54 <mburns> the rpms all have a custom string in the RELEASE part
15:53:23 <eedri> oschreib, and run 'createrepo' command
15:53:38 <mburns> it's fairly easy to do that with the variables available in jenkins
15:53:44 <mburns> and slight specfile modifications
15:53:57 <mburns> eedri: oschreib:  i don't think we want jenkins running createrepo
15:54:01 <oschreib> well, I'm not sure if jenkins should do the createrepo
15:54:05 <oschreib> mburns: lol
15:54:13 <mburns> or putting anything directly in releases
15:55:32 <mburns> having a script that runs as root (or another privileged user) on ovirt.org would help protect us from potentially bad things getting posted
15:55:59 <mburns> it could ensure that only *rpm *tar.gz *iso files get copied, for example
15:56:39 <sgordon_> #link https://bugzilla.redhat.com/show_bug.cgi?id=807761
15:56:44 <sgordon_> oschreib, for the SRPM failure ^
15:57:42 <oschreib> sgordon_: thanks
15:57:47 <mburns> ok, so are we agreed that we should be automatically moving from jenkins to nightly?
15:57:57 <oschreib> mburns: eedri : lets take it off-list?
15:58:01 <oschreib> we all agree we need this
15:58:02 <mburns> sure
15:58:36 <eedri> one last thing
15:58:36 <mburns> #action oschreib eedri mburns to discuss automatically moving jenkins built rpms to nightly releases directory on ovirt.org
15:58:57 <eedri> you can just use a local script on ovirt.org to do wget from jenkins
15:59:00 <eedri> and createrepo
15:59:13 <oschreib> eedri: I think we should have something like
15:59:19 <mburns> that's a possibility too
15:59:31 <eedri> you access the url: http://jenkins.ovirt.org/view/ovirt_engine/job/ovirt_engine_cli_create_rpms/lastSuccessfulBuild/artifact/rpmtop/RPMS/noarch/ovirt-engine-cli-2.1.3-1.fc16.noarch.rpm
15:59:34 <eedri> for example
15:59:43 <eedri> for ovirt-engine-cli
15:59:51 <eedri> d/l it to a local dir on ovirt.org and create the repo
15:59:53 <mburns> i'll write up a proposal and send to infra@
16:00:01 <oschreib> eedri: yes, but we need you to change the release version
16:00:18 <eedri> oschreib, i see, ok let's talk on infra@ovirt.org
16:00:19 <mburns> there is an option to pull last stable artifacts in a zip file
16:00:29 <eedri> mburns, right
16:00:39 <mburns> but we'll take this to the lsit
16:00:41 <eedri> anyway, jenkins can prepare whatever we want
16:00:45 <oschreib> cool
16:01:40 <mburns> #topic other topics
16:01:48 <mburns> anything else since we're already over time...
16:02:49 <sgordon_> lunch?
16:02:52 <sgordon_> :p
16:03:00 <mburns> ok, guess nothing else
16:03:05 <mburns> so...
16:03:08 <mburns> #endmeeting