14:00:35 <mburns> #startmeeting oVirt Node Weekly Sync
14:00:35 <ovirtbot> Meeting started Thu Dec  8 14:00:35 2011 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:35 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:45 <mburns> #chair jboggs pmyers
14:00:45 <ovirtbot> Current chairs: jboggs mburns pmyers
14:01:03 <mburns> #topic roll call
14:01:09 <mburns> who's here?
14:01:15 * pmyers in
14:01:35 * jboggs in
14:01:53 <mburns> #info mburns jboggs pmyers are here
14:02:13 <mburns> #topic agenda
14:02:23 <mburns> 1.  review action items
14:02:29 <mburns> 2.  Release status
14:03:05 <mburns> 3.  stateless and plugin designs
14:03:09 <mburns> anything else?
14:03:48 <mburns> 4.  Other topics
14:04:07 <mburns> ok, then we'll start
14:04:15 <mburns> #topic Action Items
14:04:42 <mburns> dougsland: any status on the patches for vdsm?
14:05:22 <mburns> #info all outstanding patches prior to yesterday are acked and pushed
14:05:40 <dougsland> mburns, not all were commit yet. Yesterday we got one commit, still working on it.
14:05:53 <dougsland> I do believe we will go without change /rhev dir to /ovirt or whatever new name.
14:06:09 <mburns> #info some vdsm patches have been merged, some still pending
14:06:34 <mburns> dougsland: seems ok for now to just get things working, but i think before the first release we should try to get that changed
14:06:39 <pmyers> dougsland: why are we not changing to /ovirt?
14:06:45 <pmyers> it seems like a trivial change (sed?)
14:07:32 <mburns> #info engine patch to add approval to webadmin UI already merged
14:07:48 <dougsland> pmyers, there is no definition which dir will be
14:07:57 <dougsland> at least not yet.
14:07:58 <pmyers> you posted the question to vdsm list?
14:08:46 <pmyers> hm, I don't see thread on vdsm-devel list
14:08:49 <mburns> #info building instructions from ovirt-node-tools rpm added to wiki
14:08:51 <mburns> #link http://ovirt.org/wiki/Node_Building#From_-tools_RPM
14:09:17 <pmyers> dougsland: can you point me at the thread on this if it does exist?
14:09:24 <pmyers> otherwise I'll start a thread
14:09:28 <dougsland> pmyers, yes, I will point you.
14:10:00 <mburns> #action dougsland to continue working on vdsm patches for registration and node/engine interoperability
14:10:34 <pmyers> dougsland: was it on vdsm-devel or some other list?
14:12:14 <mburns> #action dougsland to provide info on the thread discussing /rhev vs. /ovirt
14:12:42 <mburns> pmyers: dougsland:  tbh, for now, i'd rather worry about making registration and running vms work first
14:12:50 <mburns> then worry about naming and locations later
14:12:56 <pmyers> well, we can do it in parallel
14:12:59 <pmyers> the naming changes are trivial
14:13:08 <dougsland> pmyers, the chagnes are ready to /ovirt
14:13:29 <dougsland> pmyers, mburns http://gerrit.ovirt.org/#change,449
14:13:46 <mburns> #link http://gerrit.ovirt.org/#change,449
14:14:05 <dougsland> mburns, pmyers will start a new thread into vdsm-devel about the directory
14:14:23 <mburns> dougsland: thanks
14:14:33 <mburns> #action dougsland to take conversation to vdsm-devel
14:14:45 <mburns> ok, moving on with action items
14:14:52 <mburns> jboggs: did you post stack info to the wiki?
14:15:04 <jboggs> ive placed some into it, still a work in progress
14:15:24 <jboggs> alot is already outlined so just filling in a few bits
14:15:34 <mburns> #info stacks info is WIP on the wiki
14:15:39 <dougsland> mburns, pmyers just to share, have created https://bugzilla.redhat.com/show_bug.cgi?id=760756
14:15:59 <mburns> #link http://ovirt.org/wiki/Node_plugins
14:16:29 <mburns> dougsland: thanks
14:16:49 <mburns> ok, my personal action items:
14:16:56 <mburns> some i already outlined above
14:17:21 <mburns> First_release page on the wiki is up to date with current node status
14:17:51 <mburns> plugin related stuff (bz dependency and autoinstall params) done
14:18:04 <pmyers> #link https://fedorahosted.org/pipermail/vdsm-devel/2011-December/000395.html
14:18:06 <mburns> last action item for we was the 2.2.0 release, but we'll talk about that later
14:18:45 <mburns> #info pmyers only action item was to send plugin and stateless design to arch@ for review
14:18:53 <mburns> #link http://lists.ovirt.org/pipermail/arch/2011-December/000122.html
14:19:11 <pmyers> yeah it seems to ahve gotten some discussion
14:19:16 <pmyers> but I have not caught up on that thread overnight
14:19:55 <mburns> i'm a couple posts behind as well
14:20:17 <mburns> but comments on that can be kept on the list
14:20:27 <mburns> ok, moving on...
14:20:35 <mburns> #topic Release Status
14:20:53 <mburns> 2 things to discuss here
14:20:56 <mburns> 2.2.0 release
14:21:04 <mburns> first general release of ovirt suite
14:21:11 <mburns> #topic Release Status -- 2.2.0
14:21:24 <mburns> #info rpms, iso, release notes, source posted to wiki
14:21:35 <mburns> #link http://ovirt.org/wiki/Category:Node#Current_Release
14:21:52 <mburns> #info smoketesting done in a vm, but still pending on real hardware
14:22:05 <mburns> #action mburns to send out release notice
14:23:24 <mburns> #link http://ovirt.org/releases/stable/binary/ovirt-node-image-2.2.0-0.iso
14:23:45 <mburns> anything else on the 2.2.0 release?
14:24:22 <mburns> ok, then i'll move on
14:24:34 <mburns> #topic Release Status -- first oVirt Release
14:24:49 <mburns> Scheduled for 2012-01-31
14:24:54 <mburns> #info Scheduled for 2012-01-31
14:25:06 <pmyers> anyone foresee any issues with getting things lined up for end of Jan?
14:25:20 <mburns> #info code freeze/branching 2012-01-14
14:25:30 <mburns> i think we're in good shape overall
14:25:51 <mburns> biggest hurdle is getting vdsm in shape so we can do integrated testing
14:26:17 <mburns> we don't have anything critical  pending for this release
14:28:23 <mburns> pmyers: unless we want to try to hit the 2.3.0 release early
14:28:27 <mburns> but i'm not sure that's doable
14:28:44 <pmyers> i don't think we need 2.3.0 for Jan 31
14:28:53 <mburns> we were looking at F17 devel freeze for 2.3.0
14:29:06 <mburns> which is feb 7
14:29:22 <mburns> so we'd be cutting 3+ weeks to hit mid january
14:30:02 * mburns thinks we should branch soon and we can backport any specific fixes to 2.2.0 branch as needed
14:31:13 <mburns> #action mburns investigate branching for first release early so dev can proceed with 2.3.0 fixes
14:31:50 <mburns> #topic stateless and plugins
14:32:03 <mburns> #link http://ovirt.org/wiki/Node_Stateless
14:32:07 <mburns> #link http://ovirt.org/wiki/Node_plugins
14:32:35 <mburns> i have no updates hear other than what was in the action item review
14:32:46 <pmyers> yeah we really need to continue discussion on that thread
14:32:50 <pmyers> nothing else from my side to report
14:32:59 <jboggs> me neither
14:33:00 <pmyers> though jboggs what progress did you make on 3rd party plugins
14:33:05 <mburns> #info discussion will continue on arch threada
14:33:06 <pmyers> you made some updates to wiki right?
14:33:09 <mburns> #undo
14:33:09 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x91f73ec>
14:33:11 <mburns> #info discussion will continue on arch thread
14:33:20 <jboggs> yeah did update it, but still adding to it
14:34:13 <mburns> #action jboggs to continue updating plugin design
14:34:22 <mburns> #action mburns to continue updating stateless design
14:34:39 <mburns> #topic Other topics?
14:34:46 <mburns> anyone have anything else to discuss?
14:35:20 <mburns> going once....
14:35:38 <mburns> twice...
14:35:52 <mburns> gone.....
14:36:01 <mburns> Thanks all!
14:36:04 <mburns> #endmeeting